Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using Hylafax 6.0.5 on Fedora 13 x86_64. As there are no rpm package available for Fedora 13, I use the source tar ball to install hylafax myself. Everything seems fine during compile and install.

I try to send a fax with sendfax and encounter error:

# sendfax -n -d <fax-number> /etc/passwd
/usr/local/sbin/textfmt: No font metric information found for "Courier-Bold".
Usage: /usr/local/sbin/textfmt [-1] [-2] [-B] [-c] [-D] [-f fontname] [-F fontdir(s)] [-m N] [-o #] [-p #] [-r] [-U] [-Ml=#,r=#,t=#,b=#] [-V #] files... >out.ps
Default options: -f Courier -1 -p 11bp -o 0
Error converting document; command was "/usr/local/sbin/textfmt -B -f Courier-Bold      -Ml=0.4in -p 11 -s default >'/tmp//sndfaxp5GdJ9' <'/etc/passwd'"

It seems like there is problem with font problem. I have ghostscript-fonts installed too.

I can't find hyla.conf in path /etc/hylafax. There is no /etc/hylafax path in my file system. All configuration files seems located in /var/spool/hylafax/etc.

share|improve this question
    
Fedora 13 is long discontinued. Consider installing a newer version (or migrating to RHEL/CentOS). –  vonbrand Feb 17 '13 at 2:41

3 Answers 3

Just for clarification Hylafax uses converters in order to transform various types of MIME content find in mails to Postscript format, which BTW is the only format that can handle to send fax.

You can find the converters in the /var/spool/hylafax/mimetype/ directory in a default install. For example for the text (or plain) MIME type you will see there is a file called :

text/plain

or

text/text

With the contents of the command to be executed in order to transform the text file to PS.

The error you find is with the textfmt command executed in one of those files, so the problem can be solved by giving the correct arguments to the command line you will find in one of the aforementioned files ( man textfmt).

You can even use any other utility for converting from plain text to PostScript like a2ps.

share|improve this answer

I saw this problem few years ago. You ve got to install some PostScript files or GhostScript and check if there is a Courier-Bold. Also you have to check in what directory hylafax is searching for font files.

share|improve this answer

I ran into the same problem. The solution which worked for me can be found here: http://roeften.blogspot.ch/2010/10/converting-text-files-to-fax-fails.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.