Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

i want to increase my innodb_buffer_pool_size value to get some more performance and when i try, my select queries arises error such as "Incorrect information file in .."

i'm just adding

innodb_buffer_pool_size = 1G 
innodb_log_file_size = 256M

value in my my.cnf then restart mysql service. how can i prevent these errors? Thanks for help!

share|improve this question
1  
Please add relevant info from mysql's error log file. –  Paul Jan 8 '11 at 19:24

2 Answers 2

up vote 1 down vote accepted

when you change the innodb_buffer_pool_size size you need to remove the ib_logfile's usually located in /var/lib/mysql/ib_logfile0 /var/lib/mysql/ib_logfile2 etc. This way mysql can regenerate the pool files when you restart it.

share|improve this answer

We need more information so we can help you. Pasting what is inside the MySQL error log (usually /var/log/mysqld.log) is a great start. Also how much RAM do you have in your system? Also pasting your current /etc/my.cnf settings will help as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.