Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Server is working perfectly but when I do RDC screen is only black. This happened before and I fixed it by powering off the server via KVM/IP, but I don't want do that again. How can I fix this issue.

OS: Windows Server 2008 R2 Web Edition SP1

share|improve this question
up vote 1 down vote accepted

I've seen this happen before 3 or 4 times when a user just closes their session instead of logging out of it. Please try the things in the KB article above under JohnThePro's answer.

share|improve this answer

This often happens to me when I connect to Windows 7 x64 machine. Solution that I use is pressing Ctrl-Alt-End in the RDP window. This brings up the "lock your computer" screen. Lock-Unlock and you are in!

share|improve this answer

Here is how to work around the issue. All the above else failed for me.

I am using Windows 7 home Edition.

Before Connecting To RDP,

Click the link with the words "Remote desktop Connection" Link. Ensure you click the link with these words, not the actual URL or saved RDP name.

When the RDP window opens up, click the Options button at the bottom.

Change to Display properties by clicking the Display Tab.

On the Display Configuration Panel, Change the Screen Resolution slightly each time before clicking Connect.

This will ensure your black screen stays away.

share|improve this answer

Next time it crops up, there is a specific KB article about this issue.

share|improve this answer
thanks for answer i will remember – MonsterMMORPG Jan 21 '11 at 1:08

Tryto get it in full screen and then do an "alt-tab." Maybe it's stuck in a weird application. This technique worked for me once.

share|improve this answer
does not solve. anyway i did a kvm/ip power off and power on since i needed a solution asap. so can not test answers anymore :( – MonsterMMORPG Jan 9 '11 at 22:27

Have you tried logging in as a different user? This happens sometimes on my terminal when a session gets stuck logging out. Ending the session from the remote desktops tool fixes it.

share|improve this answer

Found this article it list quite alot of possible reasons and their solutions regarding this issue, I was able to fix my issue with by enabling sessions limits as described in the article.

share|improve this answer
So what actual change did you implement? That article may disappear next week, next month, or next year. – Hyppy Jan 21 '15 at 19:40
@karan Like Hyppy mentioned - "What actually fixed the problem?" This site is a great tool, in that information referenced elsewhere can still be found, as long as someone puts that information in the answer. – Signal15 Jan 21 '15 at 20:15

There is also another KB article with a patch for Windows Server 2008 R2.

I installed this patch to solve the issue.

When a user session is disconnected, the black screen showed up occasionnaly on reconnection.

share|improve this answer
This linked support item is for Windows Server 2008 R2 not for Windows Server 2012 as mentioned in the answer. – Fiasco Labs Jan 29 '15 at 5:59
Sorry, this was a typo. We are using only Windows 2008 R2. – Lorenz Meyer Jan 29 '15 at 6:14

UAC. UAC is the problem. That bullshit, yes. In my case the first login was successful and working, but any other consecutive attempt was not working. I was getting either a flickering(unusable) or completely black screen, on RDP or directly on the console of the 2012 R2 server. In the Application eventlogs there were lots of errors with eventID 1000(Faulting application name: explorer.exe, version: 6.3.9600.17415, time stamp: 0x54503a3a Faulting module name: unknown). UAC was disabled. I just enabled it, reboot the server, and then I was able to log in with multiple working sessions. I even disabled back UAC and reboot the server again and things were working normally. Beware of UAC :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.