Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to connect my asp.net 4.0 application to a MySQL 4.0.xx database.

I have MySQL Connector/NET 6.3.5 installed. It works great with MySQL 5+, but it says it does not support anything prior to version 5.

What should I do?

share|improve this question

1 Answer 1

You should upgrade to MySQL 5.0 and then 5.1. Before you upgrade you should backup your database and test it on the new MySQL version on a VM or another Machine before committing to the new version completely.

share|improve this answer
    
As much as I'd like to upgrade the database server, I don't own it sadly. I just connect to it with SELECT privileges only. I made a compromise and installed MySQL Connector/NET 5 instead. It works with MySQL 4, but doesnt support nice stuff in Visual Studio such as being available for use in SQLDataSource control. –  user59623 Jan 12 '11 at 1:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.