Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I first created the /trunk on domain.name

svnadmin create /trunk
svnserve -d -r /trunk

Then I tried to connect to svn://domain.name/trunk,but it doesn't exists...

So I tried svn://domain.name/,this time it works...

Why my repository /trunk maps to /?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You've created a repository folder called trunk with the first command (the -r argument tells svnserve to set the given location as the root.), but this is just the filesystem location of the repository.

I believe svnserve will always seerve the repo as the root folder in the URL (I can't see any options in the man page for overriding this, anyway).

What I think you need to is to create and commit the trunk folder into your empty repository (along with your branches and tags folders, should you desire them). My usual tactic is as follows:

On the Server:

svnnadmin create repo
svnserve -d -r repo/

On the Client:

svn co svn://domain.name/ repo/
cd repo
mkdir branches tags trunk
svn add *
svn ci -m "Base directory structure"

Then svn://domain.name/trunk will be your repository trunk.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.