Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm a student worker in the CS department of my university, so please forgive me for any unprofessional descriptions. Simplified explanations are appreciated.

I recently replaced some bad graphics cards in a few public workstations. The machines are all the same model. Before putting them back on the network I did fresh installs of RHEL---first I tried 5.4, but yum update ran into all sorts of ugly dependency errors and if I tried to remove any of the problematic packages, the whole operating system FUBAR'd. Using RHEL 5.5 gave me the same errors during install saying that "java.1.5.1-sun*" and "desktops" were missing, but yum update didn't have any dependency problems. Now that I tried logging in through the GUI, I encounter no GUI past the standard RHEL login page. The desktop is a uniform light teal and there's no system tray. An xclock window and an xterm window are open, and Firefox opens automatically, but that's it. Nothing else. What's REALLY confusing is that the computer claims that gnome is already installed, except it clearly isn't working.

Any help or advice is greatly appreciated. If it helps, our department uses kickstart to run our standard Linux installs. I can try to get the script if that would be of use.

Thank you!

share|improve this question

1 Answer 1

Check the yum installed groups versus the available groups:

yum grouplist

Installed Groups:
   Administration Tools
   Dialup Networking Support
   Editors
   GNOME Desktop Environment
   Graphical Internet
   Graphics
   .
   .
Available Groups:
   Authoring and Publishing
   Base
   Beagle
   .
   .

Then you can then try to run a groupinstall of the Gnome environment if it isn't in the Installed Groups list:

yum groupinstall "GNOME Desktop Environment"

share|improve this answer
    
Thanks, that worked! Do you have any idea why Nautilus and things failed to install in the first place? –  TKguru42 Jan 13 '11 at 14:52
    
I'm not completely sure. If you're doing the Graphical Installation, you'd need to choose "Gnome Desktop" if it prompts you. But I usually use kickstart files for installations, so the specifics escape me. –  ewwhite Jan 13 '11 at 15:01
    
We use kickstart too. I suppose we'll just have to go over the file carefully to see if it's looking for the packages in the wrong place. Thanks! –  TKguru42 Jan 14 '11 at 14:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.