Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an older HP NetServer LPr with what is apparently a Symbios SCSI card connecting to a Quantum SuperLoader 3 that is DLT based. From time to time, we seem to lose the connection to the autoloader. It's usually due to flaky power, but not totally sure why; sometimes when this happens the Autoloader's LED's are orange and it needs to be power cycled. The annoying workaround currently is to reboot the machine. As it is our production VPN and DNS server in addition to being our backup server, this is less than optimal.

In Debian (Sarge) is there not some command one can type to get the card to notice that it has the autoloader connected again?

dcr1:/proc# grep -i symbios /proc/pci
    SCSI storage controller: LSI Logic / Symbios Logic 53c895 (rev 1).
dcr1:/proc# uname -a
Linux dcr1 2.4.27-3-686 #1 Tue Dec 5 21:03:54 UTC 2006 i686 GNU/Linux
dcr1:/proc# mt status
mt: /dev/tape: No such device
dcr1:/proc# ls -l /dev/tape
lrwxrwxrwx 1 root root 8 2007-02-07 16:01 /dev/tape -> /dev/st0

That mt status command will show the actual st0 status when things are working correctly. The No such device message is usually the second clue that we need to reboot - the first clue is usually that the backups didn't run.

share|improve this question
up vote 3 down vote accepted

On Linux 2.4 you can force a scsi bus rescan by sending 'echo 1' to one of the /proc entries. I always looked it up in the SCSI_HOWTO document. I can look it up if needed.

It sounds like the drive is going offline. Have you tried the scsitur (test unit ready) or the scsinq command ?

share|improve this answer has an article that refers to this: echo "scsi add-single-device 1 0 6 0" > /proc/scsi/scsi ... I'll try it. – Kyle Hodgson Jun 9 '09 at 9:19
That's it! Of course I had to change the syntax for my host/bus/target but this did the trick. Thanks! – Kyle Hodgson Jun 9 '09 at 9:51

Have you tried removing and re-adding the 'st' (scsi tape) module? Might prevent the need for a reboot at least...

lsmod | grep st
sudo rmmod st
sudo modprobe st
share|improve this answer
This didn't work. I did get an error message though, perhaps that's why. It may pertain to a previous non-finished attempt to upgrade the kernel: Note: /etc/modules.conf is more recent than /lib/modules/2.4.27-3-686/modules.dep – Kyle Hodgson Jun 8 '09 at 18:15
Not to worry - worth a try. To be honest, you really need to move the drive off this core server, or move the core services off to a newer Debian release. Do you really want to be depending on a slightly broken Sarge box? – Mike Pountney Jun 8 '09 at 18:48
Better "Sarge with kernel upgrade status in transition" than Windows; but your point is well taken. It will also likely help to get the tape drive on the UPS, which I think is the cause of the issue in the first place. I must say, I did think the rmmod/modprobe would work. Thanks for the idea. – Kyle Hodgson Jun 8 '09 at 22:32

Maybe you need to delete the scsi device and then force a rescan. This IBM article has some ways of doing this.

share|improve this answer
Looks helpful, but I think its 2.6 related. Looks like its time I took the plunge and upgrade the machine. Thanks Kyle. – Kyle Hodgson Jun 8 '09 at 22:37

When your drive is detected correctly, run the command :

# cat /proc/scsi/scsi

and note down the result.

it should look like :

Host: scsi9 Channel: 00 Id: 01 Lun: 00
  Vendor: IBM      Model: ULT3580-TD4      Rev: 5500
  Type:   Sequential-Access                ANSI  SCSI revision: 05

on 2.4 kernels :

# echo "scsi add-single-device H C I L" > /proc/scsi/scsi

where H C I L are the SCSI address whenever the drive is detected correctly

on 2.6 kernels :

# echo “- - -” >  /sys/class/scsi_host/hostH/scan

where H is the number of the SCSI controler.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.