Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a SharePoint 2010 VM setup in VirtualBox and I was using local machine accounts to handle security on the server.

While preparing for a demo it came time to have some meaningful users on my VM image. I followed some docs on promoting my server to a Domain Controller in a new forrest.

So now I have [MachineName].SPDEMO.CONTOSO.com and I can add users as needed.

However, when I try to connect to my SharePoint sites I am getting a white screen with the error:

"Cannot connect to the configuration database"

I changed the pool identity account of each of my IIS app pools to the new Administrator account and started the services successfully but I can't get the SQL services to start up.

When I try to start them I get the following error:

Windows could not start the SQL Server (MSSQLSERVER) on Local Computer. For more information, review the System Event Log.  If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 17058.

In the event log I see the following error:

The SQL Server (MSSQLSERVER) service terminated with service-specific error %%17058.

Can I recover from this or should I roll back or just uninstall the Domain Controller role. I'd like to keep the server as a standalone DC so I can do some user profile creation/management but I need the SharePoint bits to work as well.

share|improve this question
1  
Have you changed the SQL Service account too? –  Toni Frankola Jan 10 '11 at 23:09
    
I think Toni's point is good, but to be honest I simply wouldn't mix the sharepoint and DC roles and expect a good working system afterwards. Can you not create a second small VM to host the DC role? –  RobM Jan 10 '11 at 23:19
    
I should have mentioned that I did update the SQL service account as well. The separate VM as a DC option is good but then I have to figure out all the magic to get networking between my VM instances but not outside my host where my company domain can pick them up and get confused. I was trying to avoid that extra work but if that is the best option I could head down that path. –  jjr2527 Jan 11 '11 at 2:52
    
Toni, I spoke too soon. I didn't change the sql service account because it was set up as a network service. After double checking I configured it as a user account and that cleared up the issue. Can you add that as an answer so I can mark it as such? –  jjr2527 Jan 11 '11 at 14:47
    
will add as answer. If you have HW resources add another VM for DC and SQL too. –  Toni Frankola Jan 11 '11 at 23:42

1 Answer 1

up vote 0 down vote accepted

It's probably a problem with SQL Service account, have you changed it?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.