Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have recently setup a web server with webmin, virtualmin and usermin on CentOS to host some websites and email, however I am unable to access usermin. I can access webmin from www.foobar.com:10000 but I can't access usermin from www.foobar.com:20000

This thread seems to have dealt within the same issue, however when I tried the command "telnet localhost 20000" it came back with a connection refused message. Any idea how to get this running.

I'll let you know in advance that I am a linux newbie and this is a large learning experience, so don't rule out anything if you are thinking "oh, but he wouldn't be dumb enough to forget that" or the like

share|improve this question
    
This has been solved. I reinstalled usermin, and the message that came up was to access it at server.foobar.com:20000, and that works –  Lobe Jan 13 '11 at 4:21
    
Post that as an answer, and accept it. –  Josh Jan 14 '11 at 13:48

2 Answers 2

Is port 20000 open?

netstat is a good tool to check if there is actually a service listening there in the first place. Have you restarted webmin since installing usermin?

share|improve this answer
    
I have restarted webmin, no luck. I also looked around with netstat and couldn't see a service listening on 20000. –  Lobe Jan 11 '11 at 11:59
up vote 0 down vote accepted

I solved this issue by just wiping the server and reinstalling the webmin/virtualmin/usermin software through the install.sh script they supply. Everything now seems to work perfectly

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.