Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Windows Server 2008 R2 installed as a virtual guest in my Windows 7 host via VirtualBox 4.0.

I did this to move my development activity to a controlled environment that doesn't affect my host OS when I don't want to develop.

The problem I have is that when I try to connect to my shared hosting FTP, it's slow as hell on the virtual OS but perfectly fast on the host.

I tried:

  • Disabling Windows Firewall
  • Trying several different FTP clients

Anyone else have this issue?

share|improve this question
add comment

2 Answers

Is your Win 7 host powerful enough to run Win 7 and Win 2008? Just because the Win 2008 box is a VM doesn't mean it isn't going to require much less resources to operate smoothly. Did you check your memory usage in the VM and on the host? How much memory does the host have? How much memory did you allocate to the 2008 VM? If it is too little, then it will end up doing a lot of paging and account for the poor performance. You may be simply running out of resources...

share|improve this answer
    
Highly doubtful; it runs faster than my Windows 7 box. It starts up so fast the progress bar doesn't even move. Thanks for the answer, though! I am running a Core 2 Duo E8600 + 8GB of ram, 3 of which are allocated to the VM. Also, other programs run fine and fast. It's just transfers; it either takes a minute to get a directory listing or doesn't transfer at all. –  subkamran Jan 11 '11 at 17:51
    
check your firewall setting and the type of ftp connection: is it active or passive? both required a correct setting of ports both on server and on client –  Nicola Boccardi Jan 11 '11 at 18:55
add comment
up vote 0 down vote accepted

I figured it out. In VirtualBox, I set my Network Adapter settings to use "Bridged Adapter" instead of NAT.

Bridged Adapter settings in VirtualBox

This made everything work (FTP, Web Deploy, etc.) MUCH faster.

Thanks for your comments.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.