Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a case where I need a non-priv account to be able to make a modification to the redirected printer. I know, its not advisable but we're not giving them access - changes will be made in code.

So, following the docs ( I modified the default security for new printer queues. This doesnt work though as windows doesn't seem to assign the privs you configure in the printer admin tool to redirected printer queues.

As I test I added a non-priv test user to the default security tab in the printer admin tool (control panel -> admin tools -> printer admin). I assigned it all privs (it is a test) and logged the user into the terminal server.

The redirected printers appeared as usual. However, if I open the printer properties -> security tab, the user appears in the list of accounts/groups but the options I selected (all privs) are not set. Instead the user special privs box is marked and when I click on 'advanced options' and view them, there is nothing marked.

So, something is clearing these options.... the question is, why and how can I convince it not to?


share|improve this question
up vote 0 down vote accepted

Answered my own question ... again.

I needed to take ownership of the queue and then modify the security to allow me to administer the settings.

To do that I need to run cmd/explorer or print admin tool as administrator and supply the user credentials again.... obvious now that its working.

All I have do to now is get this working in a script

share|improve this answer

This script can give the users ability to modify redirected printer settings:

share|improve this answer
Please edit your answer to include relevant information from the provided link, so that when the linked-to content is gone, your answer will still have value. – womble Aug 29 '15 at 0:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.