Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My network drive shows up in the file browser, just like my external usb-harddrive. Moving, running and editing files works. Hovering over it shows smb://lacie-2big/nasdisk .

BUT, when I want to save a file, the drive doesn't come up as an option. All I can see is my other places, including my usb-harddrive.

I am a complete newbie but I am GUESSING that it has something to do with the mount not being a "real" mount but just a shortcut to the smb location.

So I ran the tutorial at https://wiki.ubuntu.com/MountWindowsSharesPermanently about how to "mount a network drive permanently".

edited my fstab to

//LaCie-2big/nasdisk /media/nasmount cifs guest,uid=1000,iocharset=utf8,codepage=unicode,unicode 0 0

and running sudo mount -a gave me the following error:

mount: wrong fs type, bad option, bad superblock on //LaCie-2big/nasdisk, missing codepage or helper program, or other error (for several filesystems (e.g. nfs, cifs) you might need a /sbin/mount. helper program) In some cases useful info is found in syslog - try dmesg | tail or so

Now thats a very helpful error message, BUT, before I go any further, I'd be really thankful if one of you could tell me if I'm even in the right ballpark, or if my actual need: to be able to download files (ie torrents) directly to the drive, can be possible as it is already.

Question: How to fix "wrong fs type, bad option, bad superblock on //LaCie-2big/nasdisk, missing codepage or helper program" when running mount -a

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I think you are on the right track.

Try without the codepage stuff, ( take out iocharset=utf8,codepage=unicode,unicode ). verify mount.cifs exist by running which mount.cifs as root.

Does the end of the output of dmesg show anything?

share|improve this answer
    
Thanks for the reply. Running mount -a now gives me: "error, could not resolve adress for LaCie-2big". I edited the fstab to have the path smb://lacie-2big/nasdisk instead, but that gave me the error "Mounting cifs url not implemented yet. Attempt to mount smb://lacie-2big/nasdisk –  Emil Jan 12 '11 at 7:00
    
Ah, solved it now. I just replaced the lacie-2big part with the actual IP adress of the NAS and it worked. Thanks! –  Emil Jan 12 '11 at 7:05

Check to see if mount.cifs exists as a command. If it doesn't, run apt-get install cifs-utils. Part of this package is the mount.cifs helper program that fstab uses.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.