Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Taken singly, it's easy to research versions and compatibility. Version information is readily available on each single part of a platform stack, such as MySQL. You can find out the latest version, stable version, and sometimes even the percentage of people adopting it by version (personally, I like seeing numbers on adoption rates).

However, when trying to find the best possible mix of versions, I have a harder time. For example, "if you're using MySQL 5.5, you'll need PHP version XX or higher."

It gets even more difficult to mitigate when you throw higher level platforms into the mix such as Drupal, Joomla, etc.

I do consider "wizard" like installers to be beneficial, such as the Bitnami installers. However, I always wonder if those solutions cater more to the least common denominator -- be all to many -- and as such, I think I'd be better to install things on my own. Such solutions do seem kind of slow to adopt new versions, slower than necessary, I suspect.

Is there a website or tool that consolidates versioning data in order to help a webmaster choose which versions to deploy or which upgrades to install, in consideration of all the other parts of the stack?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

To be honest, unless you are planning on compiling them all from scratch, monitoring all their security announce lists, patching as necessary, you're better off picking a Linux Distro that suits your needs and working with the versions they have available pre-packaged. The main advantage to this is that you know the versions, they will work together, they versions probably won't change during the lifetime of the release, and security fixes will be backported.

If you do wish to go the route of mixing and matching the perfect versions, you also have to take into account the versions of the various dependencies that are installed on the system on which you wish to deploy. For example, you might decide that PHP 5.3.3 will be perfect, and then find out it requires a newer version of a library than is installed on your system. Upgrading the library means upgrading two more libraries that depends on, and so on. Before long, it all becomes an unmanageable mess.

In summary, unless you have very very specific requirements, stick with the versions of the LAMP components which are packages on the server which you wish to deploy on.

share|improve this answer
    
However, if you do decide that you want to start compiling the various versions, I'd recommend having a look at the DirectAdmin control panel. It's a commercial product, but it does have a very nice build system where you can mix and match versions. –  Niall Donegan Jan 11 '11 at 22:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.