Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have done multiple installs of CouchDB using sudo aptitude install couchdb sudo ap-get install couchdb

and more recently based on the instructions found at L http://wiki.apache.org/couchdb/Installing_on_Ubuntu

May I know how do I uninstall or remove all the above installations?

Best Regards. +++++++++++++++++++UPDATE++++++++++++++++++++++++

I've tried running the following commands:

apt-get remove couchdb
apt-get purge couchdb

but received the following errors:

(Reading database ... 39814 files and directories currently installed.)
Removing couchdb ...
invoke-rc.d: initscript couchdb, action "stop" failed.
dpkg: error processing couchdb (--remove):
 subprocess installed pre-removal script returned error exit status 1
invoke-rc.d: initscript couchdb, action "start" failed.
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 couchdb
E: Sub-process /usr/bin/dpkg returned an error code (1)

May I know how do i fix this?

ON issuing the command : dpkg -l | grep couchdb I received the following response:

rF  couchdb                          0.10.0-1ubuntu2                            RESTful document oriented database, system D
iF  couchdb-bin                      0.10.0-1ubuntu2                            RESTful document oriented database, programs

How do i uninstall CouchDB ? I think there's some file corruption?

share|improve this question

5 Answers 5

up vote 4 down vote accepted

Everything you install with apt-get aptitude or dpkg can be uninstalled using the same tool.

As The NinjaSysadmin pointed before use apt-get remove couchdb to uninstall

You can also use apt-get purge couchdb to remove config and other files.

To see if you have couchdb installed search for it using dpkg -l | grep couchdb

share|improve this answer
    
Excellent tip about 'purge'. –  Wraith Jan 9 '12 at 12:16

I was searching on how to completely uninstall couchdb 0.1 provided with Ubuntu in order to develop on Latest Couchbase releases.

You need to apt-get remove couchdb-bin

Found the answer in this mail archive:

http://mail-archives.apache.org/mod_mbox/couchdb-user/201008.mbox/%3C20100807021919.GH6131@orbital%3E

share|improve this answer

You should stop couchdb before remove it : $ sudo /etc/init.d/couchdb stop Then $ sudo apt-get remove couchdb $ sudo apt-get purge couchdb

share|improve this answer
    
Thanks. Worked great, unlike the top rated reply which suggests to try something the question said he already tried... –  ashgromnies Dec 17 '11 at 23:50

You can use

sudo apt-get remove couchdb

share|improve this answer

Anyone have a different answer? From what I gather, the couchdb 0.1 instance is used by the O/S itself. I am also trying to remove this, but can't. Is there a way to upgrade it to 1.0.1 at least?

FYI I've already tried to sudo apt-get remove as well as upgrade.

UPDATE

I managed to run 1.0.1 side-by side with the internal 0.10 version. It was long and complex and I didn't really know what I was doing, but the basic steps are as follows:

  • sudo apt-get remove couchdb
  • Download the .bin to some folder and extract/install (I followed this article - installing from source)
  • Chmod and chown as in that article
  • You also need to do the same to the .delete folder in installFolder/var/lib/couchdb
  • Change the port number in the local.ini file to something else
  • While you're in there, add a couchdb user
  • assign that new user to the couchdb group

Restart couchdb and you should now have 1.0.1 running on a new port as 0.10

share|improve this answer
1  
yeah I've tried the usual commands sudo apt-get remove, upgrade,aptitude remove and so on but none of them worked. i've enve tried installing couchone from couchone.com/get (ubuntu version), and ran sudo service couchdb stop. but no avail. it still runs version 0.10.0. how do we fix this? –  DjangoRocks Jan 27 '11 at 5:20
    
Is the number just reported incorrectly? I removed my 1.0.1 version but I can't seem to find (or stop) the 0.10.0 version. –  Xeoncross Feb 23 '11 at 3:48
    
I'm pretty sure you need to use a different port. Have you guys tried this? –  electrichead Feb 23 '11 at 18:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.