Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I searched about this question, found some few answers but no idea how to fix, the problem is that I realy dumb with all this!

I configured the postfix and done everything how the install how to told. It send the email, but get marked as spam! The header is this one:

Delivered-To: yachtbrasil@yachtbrasil.com
Received: by 10.223.86.203 with SMTP id t11cs837410fal;
        Wed, 12 Jan 2011 04:02:21 -0800 (PST)
X-pstn-nxpr: disp=neutral, envrcpt=yachtbrasil@yachtbrasil.com
X-pstn-nxp: bodyHash=9c6d0c64fa3a4d663c9968e9545c47d77ae0242e, headerHash=1ab8726bd17a23218309165bd20fe6e0911627cd, keyName=4, rcptHash=178929be6ed8451d98a4df01a463784e6c59b3b4, sourceip=174.121.4.154, version=1
Received: by 10.100.190.13 with SMTP id n13mr537609anf.76.1294833740396;
        Wed, 12 Jan 2011 04:02:20 -0800 (PST)
Return-Path: <sistema@brasilyacht.com.br>
Received: from psmtp.com ([74.125.245.168])
        by mx.google.com with SMTP id w2si1297960anw.132.2011.01.12.04.02.19;
        Wed, 12 Jan 2011 04:02:20 -0800 (PST)
Received-SPF: pass (google.com: domain of sistema@brasilyacht.com.br designates 174.121.4.154 as permitted sender) client-ip=174.121.4.154;
Authentication-Results: mx.google.com; spf=pass (google.com: domain of sistema@brasilyacht.com.br designates 174.121.4.154 as permitted sender) smtp.mail=sistema@brasilyacht.com.br
Received: from source ([174.121.4.154]) by na3sys010amx168.postini.com ([74.125.244.10]) with SMTP;
    Wed, 12 Jan 2011 12:02:19 GMT
Received: from localhost (server [127.0.0.1])
    (using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
    (No client certificate requested)
    by brasilyacht.com.br (Postfix) with ESMTP id 87C121290142;
    Wed, 12 Jan 2011 09:50:29 -0200 (BRST)
From: YachtBrasil <sistema@brasilyacht.com.br>
Reply-To: Vendas <rodrigoferrari@ymail.com>
Cc: YachtBrasil <sistema@brasilyacht.com.br>
To: yachtbrasil@yachtbrasil.com
Subject: teste
Date: Wed, 12 Jan 2011 09:50:29 -0200
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline
MIME-Version: 1.0
Message-Id: <20110112115029.87C121290142@brasilyacht.com.br>
X-pstn-2strike: clear
X-pstn-neptune: 0/0/0.00/0
X-pstn-levels: (S: 1.96218/99.81787 CV:99.9000 FC:95.5390 LC:95.5390 R:95.9108 P:95.9108 M:97.0282 C:98.6951 )
X-pstn-settings: 3 (1.0000:1.0000) s cv gt3 gt2 gt1 r p m c
X-pstn-addresses: from <sistema@brasilyacht.com.br> [db-null]

I'm out of ideas on how to fix this, I think it's dns issue, but I have marked the spf inside my tinydns =(

Is there anything I can check to know why this email is marked as spam? Any help will be appreciated!

Thanks and sorry for my bad english.

share|improve this question
add comment

3 Answers

You found no fix because there is no single fix - this is explained in most of the answers.

Most providers will not tell you about the methods they use for classifying spam. The nature of Bayesian filtering results in a situation where the admin does not actually know how the filter classifies messages as spam.

You've already got SPF set up - but are your records restrictive?

"v=spf1 a mx ?all"
  • apparently not.

Are you rate limiting your messages? Does you're host appear in any of the RBLs?

Unfortunately this is not really solve without a lot of knowledge / effort / trial+error

share|improve this answer
add comment

For a start you need a static address with a PTR record pointing to your A record. Otherwise you look like a spammer.

Add an SPF record for your mail server allowing it to send email. Something like v=spf1 a -all would be appropriate. I recommend mail servers FQDN (Fully Qualified Domain Name) should not be the same as your domain name. Something like mail.example.com or smtp.example.com for domain example.com is appropriate. The domain should have an SPF record like v=spf1 mx ?all, although I prefer v=spf1 mx -all once things are working.

Consider adding a DKIM signature to all outgoing email.

I did a post on Setting up an Email Server a while ago. You may want to look at it and my Email Policy.

share|improve this answer
1  
note that BillThor's suggestion of needing a PTR record is really important. You will more than likely need to get your ISP to define this PTR record on your behalf. I've been able to define my own PTR records when I had access to entire class C networks but had to rely on the ISP when I was dealing with smaller network blocks. –  Patrick R Mar 25 '11 at 12:53
add comment

i think this is not an spf issue.

Received-SPF: pass (google.com: domain of sistema@brasilyacht.com.br designates 174.121.4.154 as permitted sender) client-ip=174.121.4.154;

As you can see, your server passed the spf check. btw. here you can test your spf-records: SPF Record Testing Tools

may be the problem is the content analysis, which you can see in the additional headers: X-pstn-*

protected by Postini

Interpret message header tags

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.