Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We've recently bought two Dell PowerEdge R710 servers with Perc 6i controllers and 6x 135GB SAS Drives.

We'd done some pretty extensive testing on a Dell PowerEdge R510 server with a Perc 6i and 4x 135GB SAS Drives running FreeBSD 8.1 for it's wonderful ZFS support and mfiutil.

We hadn't had any problems with the R510 and had got to a point where we where happy with the performance of ZFS.

Since running FreeBSD 8.1 on the R710 we've been getting errors from the RAID controller.

mfi0: COMMAND 0xffffff80005d1770 TIMEOUT AFTER 6178 SECONDS

This usually brings the system to a stand still. But it doesn't always happen, and performs very well up until it does happen. We've been running the disk as 3 mirrored drives striped in ZFS. So far we've noticed that running the drives with RAID10 on the RAID seems to work without errors (still testing).

At first I thought hardware error as we'd been running FreeBSD on the R510 with the same controller without any issues. But both R710 have the same issue. All controllers are running the same firmware.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I think our servers are rock solid now.

What we did. Made sure that performance was set to maximum in the BIOS, also possibly the most important part was disabling the C-states and C1E.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.