Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I got a big problem when I added a new zone to my current Bind configuration.

===============/etc/named.conf===============

include "/etc/rndc.key";

controls {
        inet 127.0.0.1 port 953
        allow { 127.0.0.1; } keys { "rndckey"; };
};

acl "trusted" { 127.0.0.1; 208.43.81.157; 69.4.236.88; };

options {
        directory "/var/named";
        allow-query { any; };
        recursion yes;
        allow-recursion { trusted; };
};

zone "." {
        type hint;
        file "root.hints";
};

zone "2comu.com" {
        type master;
        file "2comu.com.db";
        allow-update { none; };
};

zone "usa-diamond.com" {
        type master;
        file "usa-diamond.com.db";
        allow-update { none; };
};

===============/var/named/2comu.com.db===============

$TTL    86400  
@       IN      SOA     ns1.2comu.com. root.2comu.com. (  
        2011011101  
        3600  
        300  
        3600000  
        3600 )  
        IN      NS      ns1.2comu.com.  
        IN      NS      ns2.2comu.com.  
        IN      MX      10      email.2comu.com.  

ns1.2comu.com.  IN      A       208.43.81.157  
ns2.2comu.com.  IN      A       69.4.236.88  
www.2comu.com.  IN      A       208.43.81.157  
ftp.2comu.com.  IN      A       208.43.81.157  
email.2comu.com.        IN      A       208.43.81.157  

===============/var/named/usa-diamond.com===============

$TTL    86400  
@       IN      SOA     ns1.2comu.com. root.usa-diamond.com. (  
        2011011115  
        3600  
        300  
        3600000  
        3600 )  
        IN      NS      ns1.2comu.com.  
        IN      NS      ns2.2comu.com.  

www.usa-diamond.com.    IN      A       208.43.81.157  

================================================================

All of the configurations inside domain 2comu.com work well. But when www.usa-diamond.com doesn't work at all. When I tried "dig +trace www.usa-diamond.com", I got the following message

================================================================

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2 <<>> +trace usa-diamond.com  
;; global options:  printcmd  
.                       517603  IN      NS      c.root-servers.net.  
.                       517603  IN      NS      d.root-servers.net.  
.                       517603  IN      NS      e.root-servers.net.  
.                       517603  IN      NS      f.root-servers.net.  
.                       517603  IN      NS      g.root-servers.net.  
.                       517603  IN      NS      h.root-servers.net.  
.                       517603  IN      NS      i.root-servers.net.  
.                       517603  IN      NS      j.root-servers.net.  
.                       517603  IN      NS      k.root-servers.net.  
.                       517603  IN      NS      l.root-servers.net.  
.                       517603  IN      NS      m.root-servers.net.  
.                       517603  IN      NS      a.root-servers.net.  
.                       517603  IN      NS      b.root-servers.net.  
;; Received 500 bytes from 208.43.81.157#53(208.43.81.157) in 0 ms  

com.                    172800  IN      NS      j.gtld-servers.net.  
com.                    172800  IN      NS      d.gtld-servers.net.  
com.                    172800  IN      NS      e.gtld-servers.net.  
com.                    172800  IN      NS      i.gtld-servers.net.  
com.                    172800  IN      NS      f.gtld-servers.net.  
com.                    172800  IN      NS      m.gtld-servers.net.  
com.                    172800  IN      NS      b.gtld-servers.net.  
com.                    172800  IN      NS      k.gtld-servers.net.  
com.                    172800  IN      NS      l.gtld-servers.net.  
com.                    172800  IN      NS      c.gtld-servers.net.  
com.                    172800  IN      NS      h.gtld-servers.net.  
com.                    172800  IN      NS      a.gtld-servers.net.  
com.                    172800  IN      NS      g.gtld-servers.net.  
;; Received 505 bytes from 192.33.4.12#53(c.root-servers.net) in 3 ms  

usa-diamond.com.        172800  IN      NS      ns1.2comu.com.  
usa-diamond.com.        172800  IN      NS      ns2.2comu.com.  
;; Received 107 bytes from 192.48.79.30#53(j.gtld-servers.net) in 177 ms  

;; Received 33 bytes from 208.43.81.157#53(ns1.2comu.com) in 0 ms  

=========================================================================

It seems I can't get any answer from ns1.2comu.com.

Can anyone give some suggestions?

Thanks a lot.

Bob

share|improve this question
    
Did you setup the proper GLUE records? –  Zypher Jan 13 '11 at 15:29
    
After I upgrade my Bind through yum, everything works fine now! It might be some bugs in the old Bind version I used before. –  Bob Jan 13 '11 at 16:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.