Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When using mod_deflate in Apache2, Apache will chunk gzipped content, setting the Transfer-encoding: chunked header.

Is there any setting that would change Apache's default behavior, and have Apache set a Content-length header instead of chunking the response?

share|improve this question
    
Is there a particular reason you want to disable Chunked encoding? IIRC it's a requirement in HTTP/1.1 whenever any other encoding type is set & HTTP keepalive is in use. –  voretaq7 Jan 13 '11 at 20:27

2 Answers 2

Have you tried SetEnv force-response-1.0 1 ?

share|improve this answer

That would mean Apache would have to buffer the compressed output just to calculate the content-length before sending any of the response. I don't know of such a setting, and I'd be surprised if it was supported.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.