Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have had a problem writing to a Samba share. I believe this person has the answer, but I do not know how to do this, does someone know how to do this?

Thank you very much,

On the Samba server, you need to ensure that the nobody user has write permissions to /Windows_Backups/DC. You're forcing everyone to be impersonated by the nobody account, so that account will need file-level permissions on that share directory. Samba will respect local permissions when figuring out who can write where, in this case it is somewhat like Windows.

share|improve this question

1 Answer 1

It looks like your Samba service is setup to use the 'nobody' user account. 'nobody' is one of the default system accounts on UNIX.

So, on your UNIX system, you need to investigate what the permissions are for the '/Windows_Backups/DC' directory and the files within that directory, and make sure that the 'nobody' account can read/write/execute.

On the UNIX system, you will need to use a command called 'man' in order to find out more about 'chmod' and 'chown'.

Proceed with care and take lots of notes about the initial settings and the changes you made (and how you made them), or call in a Linux or UNIX guy/girl.

share|improve this answer
    
you can setup samba to use a regular user account intead of "nobody" by just editing the smbusers file. –  djangofan Mar 20 '12 at 21:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.