Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server that only a couple people will be using so I have not purchased any CAL's for it. As I understand, this means I can not use "terminal services" or Remote Desktop Services.

How can I make it so that normal users can remote into it just like I can as an admin? I have added them to the remote desktop users group but that did not help. Thanks

share|improve this question
    
What is the message they are getting? Is it prompting for logon details and then rejecting? What OS are the clients on, and are you forcing Network Level Authentication for the Remote Desktop? –  Mark Henderson Jan 14 '11 at 3:00
    
The clients are on windows 7. If they are part of the remote desktop user group then it will ask for log on info, then open up the remote desktop window but give the error below. If they are not part of the group it does not even open that new window. I am only allowing connections from computers with Network Level Authentication. –  Tony Grosinger Jan 15 '11 at 16:26
add comment

2 Answers

Enabling Remote Desktop (in the System properties) and placing the users in the Administrators or Remote Desktop Users local groups should be enough, as the default policy settings for a Windows system allow RDP access to members of those two groups; as long as you don't want more than 2 concurrent connections to the server, it will happily handle them without need for any additional licensing.

If the server is in a domain, you should check applied GPOs, which could be restricting RDP access to it. You can use gpresult.exe for this. The relevant settings are in Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> User Rights Assignment.

share|improve this answer
add comment

You have to go to the System Properties. Here you will find the tab named Remote. On this tab you can select the remote users

share|improve this answer
    
They are already added. I get the error "To log on to this remote computer, you must be granted the Allow log on through Terminal Services right..." I have looked for this but since I do not want to use Terminal Services and do not have the roll enabled, I can't do that. –  Tony Grosinger Jan 15 '11 at 4:48
    
it could be that there is a group policy that is not allowing them to logon - to test this deny the group policy applying to the server... –  Trozz May 5 '11 at 11:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.