Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have moved my virtual box hard drive (.vdi file) from windows7 on a laptop, to windows7 on a desktop. No big deal I thought. The OS is ubuntu 10.10. Now networking is broken. I don't have a solid understanding of windows networking, maybe someone can help.

Anyway, the networking no longer works. I've tried to setup eth0. I have virtualbox setup in bridge mode, my wifi connection on windows to an intel card on the virtualbox side. I think it might be something to do with windows not allowing the connection to bridge properly (security issues).

I've provided some screenshots, which will hopefully help. alt text alt text

share|improve this question

closed as off topic by Falcon Momot, Jacob, Ward, Jenny D, growse Jun 23 '13 at 11:54

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

What I need to do was find the network interface.

# Pro Tip: use the -a flag to show any disabled interfaces along with enabled ones.
ifconfig -a
...
eth3 Link encap:bla bla bla

After finding eth3 I replaced all occurrences of eth0 with eth3 in the config file:

sudo nano /etc/network/interfaces :

auto eth3
iface eth3 inet static
... etc

Then restarted networking:

sudo /etc/init.d/networking restart
share|improve this answer

Remove the following file in your Ubuntu VM:
/etc/udev/rules.d/70-persistent-net.rules

Restart your VM and you would have internet / network access, as long as your Windows Host is properly connected to the internet. If for any reason you can't seem to go out to the internet, try to ping Host from Guest, and try to disable Windows firewall on the Host.

I had a similar / exact issue and deleting the above file helped.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.