Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have broadband connection in my laptop. It's getting the IP by protocol. configuration is :

ip : 192.168.1.2
subnet : 255.255.255.0
gateway : 192.168.1.1

Now I am curious, In IPV4 properties when instead of choosing "Obtain an IP address automatically", I choose "Use the following IP address" and configure everything same, why it do not work? Do DHCP do not work when we configure the IP manually? (operating system : windows-7)

EDIT : After configuring the ip manually, when I used ipconfig/all , it's showing dhcp enabled : NO. I am not doing it. Why it got disabled automatically? and how to enable it?

 DHCP Enabled. . . . . . . . . . . : No
  Autoconfiguration Enabled . . . . : Yes
  IPv4 Address. . . . . . . . . . . : 192.168.1.2(Preferred)
  Subnet Mask . . . . . . . . . . . : 255.255.255.0
  Default Gateway . . . . . . . . . : 192.168.1.1
  NetBIOS over Tcpip. . . . . . . . : Enabled
share|improve this question

closed as off topic by Zoredache, jscott, Iain, Jason Berg, Ward Jan 14 '11 at 15:05

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
If there is no device acting as a DHCP server you can,t get DHCP. –  Zoredache Jan 14 '11 at 14:31
    
My modem is working as dhcp server. –  user58859 Jan 14 '11 at 14:39
1  
What is not working? Ping to an IP, surfing the web, ... What about DNS? tsg –  tsg Jan 14 '11 at 14:49
    
I can ping to my gefault gateway, that is my modem. But I can't surf the web. "network and sharing center" shows "No internet access". And I don't know , what to check in DNS. –  user58859 Jan 14 '11 at 14:54

1 Answer 1

up vote 2 down vote accepted

Chances are, if you only changed the IP, you forgot the DNS settings. Switch back to using DHCP, and when you have an IP, and you can get to the internet, click Start, Run, type cmd, and hit OK. When the box comes up type:

ipconfig /all

You should see output that looks like this:

Ethernet adapter Local Area Connection:

Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Controller
Physical Address. . . . . . . . . : 00-00-00-00-00-01
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::dc07:7edd:a65d:df5%11(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.2(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Friday, January 14, 2011 8:01:10 AM
Lease Expires . . . . . . . . . . : Saturday, January 15, 2011 8:01:09 AM
Default Gateway . . . . . . . . . : 192.168.1.1

DNS Servers . . . . . . . . . . . : 192.168.1.1

The last line is what you're interested in. Go back to your network settings, and where you specified the IP address, there are 2 boxes at the bottom of the same window that say DNS Server. Type in the address you see listed in the "DNS Servers" line above. If you have multiple addresses, type both in. Save your settings, and you should be good.

I'm curious though as to why you'd want to assign yourself an IP address if you have a working DHCP server on your ISP provided modem?

share|improve this answer
    
Thanks , It's working now. –  user58859 Jan 14 '11 at 15:04
    
There is no specific reason as such. I was curious why it was not working. –  user58859 Jan 14 '11 at 15:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.