Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an Ubuntu 10 x64 server edition machine. I got a second IP and configured /etc/network/interfaces like so (actual IPs and gateways removed):

auto lo
iface lo inet loopback

#iface eth0 inet dhcp

auto eth0
auto eth0:0

iface eth0 inet static
address [ my first IP ]
netmask 255.255.255.0
gateway [ my first gateway ]

iface eth0:0 inet static
address [ my second IP ]
netmask 255.255.255.0
gateway [ my second gateway ]

/etc/apache2/ports.conf:

Listen 80
NameVirtualHost [ my first IP ]:80
NameVirtualHost [ my second IP ]:80

<IfModule mod_ssl.c>
    # If you add NameVirtualHost *:443 here, you will also have to change
    # the VirtualHost statement in /etc/apache2/sites-available/default-ssl
    # to <VirtualHost *:443>
    # Server Name Indication for SSL named virtual hosts is currently not
    # supported by MSIE on Windows XP.
    Listen 443
    NameVirtualHost [ my first IP - some site is running SSL successfully using it ]:443
</IfModule>

<IfModule mod_gnutls.c>
    Listen 443
</IfModule>

/etc/apache2/sites-enabled/mysite.conf:

<VirtualHost [my second IP ]:80>
 ServerName mysite.com
 Include /var/www/mysite.com/djangoproject/apache/django.conf
</VirtualHost>

Then when visiting http://[mysite].com:80 or http://[mysite].com, I get:

An error occurred during a connection to [mysite].com.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

My guess is that the configuration file is not being picked up, and apache is therefore looking for the default-ssl file, which is not in conf-enabled. If I were to configure that file properly, it seems I would successfully connect to whatever default directory is specified in the default-ssl file. But I want to connect to my website.

Any ideas?

Thanks in advance!

share|improve this question
add comment

1 Answer 1

I cleared my browser cache. Then I re-visited the page and was able to connect correctly without a problem. Looks like this was a case of user error.

share|improve this answer
1  
Please mark this answer as correct, then. Thanks! –  Andrew M. Jan 14 '11 at 20:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.