Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got the centos server with WHM. The mail server is exim. I need exim put all messages in queue and not sending directly.Though I've added the queue_only option to exim configuration and the messages are collected in the queue now. Afterwards I've found out that someone is calling exim -q to process the queue every once in a while. I've found the following cron job:

0 6 * * * /scripts/exim_tidydb > /dev/null 2>&1

which I beleive has been used to process the exim queue. Also I suspect that script was installed alongside with WHM. Surely I've commented it out and was expecting everything to work just fine. But that didn't happen. I still get the exim queue processed once in a while.

Am I missing anything? What may cause my exim queue to process?

Here is cat /etc/exim.conf | grep queue

queue_only
deliver_queue_load_max = 3

Thanks

share|improve this question

1 Answer 1

up vote 2 down vote accepted

exim_tidydb shouldn't cause a queue run, it just cleans up the hints files

The exim daemon itself might be causing the queue runs depending on the options its started with. Does it have a -q specified (like -q30m)?

If you really, really don't want it to deliver anything while you're looking into this, try setting hold_domains = *

share|improve this answer
    
Thanks for hold_domains option. –  Xobb Jan 14 '11 at 20:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.