Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Windows 2003 web edition server that I can't seem to get the SMTP relay working.

BT4 shows port 25 open. When I try use telnet to test it on my desktop I get:

  Connecting To XXX.XXX.XXX.XXX...Could not open connection to the host, on port 25: Connect failed.

From the server I get:

Microsoft Telnet> o 127.0.0.1 25
Connecting To 127.0.0.1...

Connection to host lost.

There isn't anything useful in the logs.

Any ideas?

share|improve this question
    
Does NetStat show port 25 is open? Is the SMTP service started, is there a firewall installed? –  Ed Fries Jan 15 '11 at 1:26
    
@Ed Fries -- Netstat shows SMTP, Windows Firewall is the only firewall and port 25 is open, the SMTP Virtual Server in IIS is running. –  NitroxDM Jan 15 '11 at 5:49
    
Does it allow connections from any host? What ip/hostname is it listening on? –  Tuinslak Jan 15 '11 at 10:50

2 Answers 2

Windows Firewall doesn't block connections on the loopback. Check on the smtp interface on which IP it is listening first.

Did you try to restart the windows smtp service ? Maybe it's in an invalid state.

share|improve this answer
    
It's listening on (All Unassigned), and it's static IPs on port 25. –  NitroxDM Jan 17 '11 at 14:59
    
Restarting the service hasn't helped. I don't think it's in an invalid state as it relays messages. –  NitroxDM Jan 17 '11 at 15:05
    
do you have any AV on it ? Symantec & co monitor traffic on port 25 for Virus, even the desktop edition –  Mathieu Chateau Jan 20 '11 at 18:23
up vote 0 down vote accepted

I have yet to connect using telnet.

However I ruled out iis using smtpdiag.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.