Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having trouble with an cups installation. It seems to be in a broken state. When i try to reinstall it it stalls, the same if i try to remove it completely.

I am running the server version 64 bit of Ubuntu 10.10 with kernel Linux version 2.6.35-22-server.

When i try to start the cups daemon with the following command

sudo service cups start

It just stays there and nothing happens.

I have tried to remove it, to be able to reinstall it, with the following command

sudo apt-get purge cups

It finally stalls with the following message

Removing cups ...

After that nothing happens.

The process tree for the apt-get command looks like this.

1404 1404 1404 ? 00:00:00 sshd
26495 26495 26495 ? 00:00:00 sshd
26581 26495 26495 ? 00:00:00 sshd
26582 26582 26582 pts/4 00:00:00 bash
27158 27158 26582 pts/4 00:00:00 apt-get
27172 27172 27172 pts/2 00:00:00 dpkg
27176 27172 27172 pts/2 00:00:00 cups.prerm
27178 27172 27172 pts/2 00:00:00 stop

I have tried to leave the process running for a while to see if i get any error messages but without success. To get out of it I have to kill the processes.

sudo dpkg --configure cups

dpkg: error processing cups (--configure):
 package cups is already installed and configured
Errors were encountered while processing:
 cups

sudo dpkg --status cups

Package: cups
Status: purge ok installed
Priority: optional
Section: net
Installed-Size: 8292
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Version: 1.4.4-6ubuntu2.3
Replaces: cupsddk-drivers (<< 1.4.0)
Provides: cupsddk-drivers
Depends: libavahi-client3 (>= 0.6.16), libavahi-common3 (>= 0.6.16), libc6 (>= 2.7), libcups2 (>= 1.4.4-3~), libcupscgi1 (>= 1.4.2), libcupsdriver1 (>= 1.4.0), libcupsimage2 (>= 1.4.0), libcupsmime1 (>= 1.4.0), libcupsppdc1 (>= 1.4.0), libdbus-1-3 (>= 1.0.2), libgcc1 (>= 1:4.1.1), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.8+dfsg), libijs-0.35, libkrb5-3 (>= 1.6.dfsg.2), libldap-2.4-2 (>= 2.4.7), libpam0g (>= 0.99.7.1), libpaper1, libpoppler7, libslp1, libstdc++6 (>= 4.1.1), libusb-0.1-4 (>= 2:0.1.12), zlib1g (>= 1:1.1.4), debconf (>= 1.2.9) | debconf-2.0, upstart-job, poppler-utils (>= 0.12), procps, ghostscript, lsb-base (>= 3), cups-common (>= 1.4.4), cups-client (>= 1.4.4-6ubuntu2.3), ssl-cert (>= 1.0.11), adduser, bc, ttf-freefont, cups-ppdc
Recommends: foomatic-filters (>= 4.0), cups-driver-gutenprint, ghostscript-cups
Suggests: cups-bsd, foomatic-db-compressed-ppds | foomatic-db, hplip, xpdf-korean | xpdf-japanese | xpdf-chinese-traditional | xpdf-chinese-simplified, cups-pdf, smbclient (>= 3.0.9), udev
Breaks: foomatic-filters (<< 4.0)
Conflicts: cupsddk-drivers (<< 1.4.0)
Conffiles:
 /etc/fonts/conf.d/99pdftoopvp.conf a5221cfad70a981c80864229ef56586d
 /etc/logrotate.d/cups 5bb41fa9900f0d1c565954405a2bd7c4
 /etc/default/cups 2b436fbb1a32b82b6aba45a76a1d7e40
 /etc/pam.d/cups ff2488324854f7b1e892bb0df062d5f0
 /etc/init/cups.conf 1a3cd022e8474e3d2b44640f33ce68e3
 /etc/ufw/applications.d/cups 29e98a6d850da251e180c3d68dec2bd3
 /etc/apparmor.d/usr.sbin.cupsd 60c4b26bfd5c033baa3dd48a3b2e9911
 /etc/cups/cupsd.conf e2c7ec15835ea0939e5e86f7c6efcc03
 /etc/cups/snmp.conf 2326a8af1e112676d55245bc5eb459ca
 /etc/cups/cupsd.conf.default a68d54d76021e857dd1d64edf57d36c5
Description: Common UNIX Printing System(tm) - server
 The Common UNIX Printing System (or CUPS(tm)) is a printing system and
 general replacement for lpd and the like.  It supports the Internet
 Printing Protocol (IPP), and has its own filtering driver model for
 handling various document types.
 .
 This package provides the CUPS scheduler/daemon and related files.
Original-Maintainer: Debian CUPS Maintainers <pkg-cups-devel@lists.alioth.debian.org>

Would be greatful if someone could provide some help on how to solve this issue.

share|improve this question
    
Please properly format your preformatted text (e.g., command output); it's almost illegible otherwise. I've fixed it for you in this post. –  larsks Jan 16 '11 at 14:23
1  
You say you solved it, but how? –  random Feb 26 '11 at 23:41

2 Answers 2

Try running dpkg -a --configure. This should tell you what problems are being encountered. I have found broken packages don't uninstall.

Rarely, I have had to edit the install scripts to skip a failing step. Once I get the package installed, I uninstall, purge, and reinstall the package.

share|improve this answer
    
Running the command you suggest doesn't produce any output for me. Sorry if I dont provide more information. I have search the logs to see if they output any thing that can give me a hint, but havent found anything. Maybe a fresh install will be the only solution. –  user67046 Jan 19 '11 at 18:55

Also, try to dpkg --force-all --remove cups && aptitude install cups. It worked for me once with another (broken) package.

share|improve this answer
    
I tried to run this command, for me it produces the same result as when i tried with sudo apt-get purge cups. It stalls there and nothing more happens. –  user67046 Jan 19 '11 at 18:53
1  
I think I managed to get rid of it. I commented out some lines in the cups.prerm script. After that the dpkg --force-all --remove cups would finish. I also needed to remove some depending packages that was left. There after could I reinstall cups again successfully. Now I have it up and running again. Thanks a lot! –  user67046 Jan 19 '11 at 20:54
    
If you can submit the line to debian's bugtracker as a bug. –  Krzysztof Hasiński Jan 20 '11 at 9:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.