Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have OS X Server 10.6.5 running on a new Mac Mini (server model), serving several functions among which is iChat Server (iChat and Pidgin on Windows as clients). In the iChat log in Server Admin, I kept seeing entries about connecting to proxy.eu.jabber.org. It's for our office network and I wasn't excited about external access to it, so I disabled server-to-server XMPP federation and now the connections just time out. But why is it doing that in the first place?

Sample log entry:

(datetime) (servername)jabberd/resolver[portnum]: [xmpp-server._tcp.proxy.eu.jabber.org resolved to 208.68.163.220:5269 (300 seconds to live)

then:

sending dialback auth request for route '(full server hostname)/proxy.eu.jabber.org'

A couple minutes later, it comes back with:

dialback for outgoing route '(full server hostname)/proxy.eu.jabber.org' timed out
share|improve this question

migrated from superuser.com Jan 16 '11 at 15:18

This question came from our site for computer enthusiasts and power users.

    
Does it try to connect when no users are connected to your machine? It might be a client configuration issue, as you either connect because of proxied file transfers, or because of server to server communication. –  Daniel Beck Jan 15 '11 at 10:19
    
It doesn't appear to be user-dependent, no. It seems like it's just trying to network itself. –  Mr. Jefferson Jan 17 '11 at 3:16

1 Answer 1

up vote 1 down vote accepted

That is due to iChat bridging your jabber server to the jabber network in order to be able to talk to other jabber users, its configured to do so by default.

share|improve this answer
    
So it's trying to join itself to a larger jabber network...that makes sense. I'm just a little surprised that after I disable that (server-to-server federation?) it keeps trying and timing out, instead of just stopping altogether. –  Mr. Jefferson Jan 17 '11 at 3:17
    
Yeah, Mac OS X server is surprisingly dodgy on some aspects, I'm pretty sure that it still tries to connect but disabling the option just makes it not register itself into the list of available servers. Sometimes the best option is just editing the conf files by hand. –  lynxman Jan 17 '11 at 8:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.