Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When my system boots up it shows the following message.

Bringing up loopback interface:  [  OK  ]
Bringing up interface eth0:  RTNETLINK answers: Invalid argument
[  OK  ]
Bringing up interface eth1:  RTNETLINK answers: Invalid argument
[  OK  ]
Bringing up interface eth2:  RTNETLINK answers: Invalid argument
[  OK  ]
Bringing up interface eth3:  RTNETLINK answers: Invalid argument
[  OK  ]

Why is this happening. Normally it does not give the message RTNETLINK answers: Invalid argument

I did ifconfig and the output is

eth0      Link encap:Ethernet  HWaddr 00:00:50:6D:56:B4  
          inet addr:120.0.10.137  Bcast:120.0.255.255  Mask:255.255.255.0
          inet6 addr: fe80::200:50ff:fe6d:56b4/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:214 (214.0 b)
          Base address:0xa000 

eth1      Link encap:Ethernet  HWaddr 00:00:50:6D:56:B5  
          inet addr:121.0.10.137  Bcast:121.0.255.255  Mask:255.255.255.0
          inet6 addr: fe80::200:50ff:fe6d:56b5/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:214 (214.0 b)
          Base address:0xc000 

eth2      Link encap:Ethernet  HWaddr 00:00:50:6D:56:B6  
          inet addr:128.0.10.137  Bcast:128.0.255.255  Mask:255.255.255.0
          inet6 addr: fe80::200:50ff:fe6d:56b6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1006 (1006.0 b)  TX bytes:396 (396.0 b)
          Interrupt:16 

eth3      Link encap:Ethernet  HWaddr 00:00:50:6D:56:B7  
          inet addr:123.0.10.137  Bcast:123.0.255.255  Mask:255.255.255.0
          inet6 addr: fe80::200:50ff:fe6d:56b7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:728 (728.0 b)  TX bytes:396 (396.0 b)
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:14 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:980 (980.0 b)  TX bytes:980 (980.0 b)

What could be the reason for the message and how to change this to normal?

Thanks

share|improve this question
    
Which linux? What special options are present in your configuration-files (mtu, txqueuelength, ...)? –  Nils Oct 24 '12 at 19:28
add comment

3 Answers

My guess is that you have changed your IP address. Please ensure that the IP address,Mask, and Gateway are of the same class (class A or B or C)

My next guess is that you have changed from a "DHCP" to a "static" address. If this the case then make sure that the administrator has removed the IP address from the DHCP scope, because the DHCP scope is the owner of the address. Your config should look something like this

root@servername network-scripts]# vi ifcfg-eth0

DEVICE=eth0
BOOTPROTO=static
IPADDR=10.206.2.4
GATEWAY=10.206.255.255
NETMASK=255.255.0.0


root@servername network-scripts]# service network restart

Hope this is a help

share|improve this answer
add comment

This may have something to do with the options you have set in the /etc/sysconfig/network-scripts/ifcfg-eth* files. You may have some incorrect settings in there.

share|improve this answer
add comment

From a brief look, your netmasks and/or broadcast addresses seem wrong.

If you're on a network which is 121.0.10.0/24 then the broadcast address should normally be 121.0.10.255, not 121.0.255.255 like you have. I don't know whether this would actually cause the errors you're seeing or whether it's a "red herring", but your network config definitely seems wrong to me and needs some careful looking at IMO.

http://jodies.de/ipcalc?host=121.0.10.137&mask1=24&mask2=

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.