Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an old Windows 2000 machine that I'm trying to replace because it is freezing periodically. It is used primarily for email but it does need to be connected to the two linux file servers ("dino1" and "dino2") that are in the office.

When I tried to get the new Windows 7 machine to connect I can't find the user account that was being used (or I can't log on to the share). On the old machine the users all logged in as Administrator on the local machine and entered the password ("fuzzypickels") to log onto the share. To me, it seems like the username ought to be Administrator, but when I enter that with "fuzzypickels" it gives me an error that I've got either the username or the password or both incorrect.

Is there something missing in my assumptions? Or is there something I can do to recover the username from the old machine?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

I ended up solving this problem by changing a setting on the windows machine rather than changing the config on the Samba server.

What I did is I added a value under one registry key to enable backwards-compatible ntlm authentication.

Computer\HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa

Under this key, I added a new DWORD value called LmCompatibilityLevel and set it to 0x00000001 (1).

After this I was able to connect to the Samba servers.

share|improve this answer
add comment

Usernames are not case sensitive on windows, but they are on linux/unix/samba. Windows does a lot of black magic with usernames (in the olden days, for certain DOS-era compatibility services, they sometimes went ALL CAPS...)

Doublecheck if you need Administrator or administrator.

Common practice on unix is to stick to lowercase usernames.

There is experimental support in later Samba versions for the new authentication, which can be turned off on the Samba side. So you can leave Windows 7 boxes to use the new authentication with their Windows 2008 domain controller, but have it disabled when they talk with a Samba server.

share|improve this answer
    
I have verified that the username is indeed "Administrator" and the issue still persists. –  Rister Jan 17 '11 at 16:33
    
Well, then you will have to dig into your Samba settings. What version of Samba and which Samba authentication method and which Samba user database system are you using (i.e. how do you add users to your Samba setup)? You can also try setting up a wide open 'Public' share on the Samba machine and see if you can get that to work on your Win7 box, or setup a new low-case user in your *nix & Samba. Also, check for allowed IP address limits in your Samba setup. –  DutchUncle Jan 17 '11 at 16:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.