Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a question about using Google Apps for handling emails. I don't want to set up a whole entire mail system on my server, so I decided to use Google Apps. The ownership of my domain is approved, and now I'm trying to change the MX records in the zone file of my domain. But I think I'm doing wrong, it doesn't work.

I want to use mail.mydomain.com as a adress to the mail server for POP, SMTP and IMAP. My zone file looks like this:

$TTL 86400
@   IN SOA ns1.first-ns.de. postmaster.robot.first-ns.de. (
    2011011700   ; serial
    14400        ; refresh
    1800         ; retry
    604800       ; expire
    86400 )      ; minimum

@                        IN NS      robotns3.second-ns.com.
@                        IN NS      robotns2.second-ns.de.
@                        IN NS      ns1.first-ns.de.

@                        IN A       111.111.111.111
localhost                IN A       127.0.0.1
www                      IN A       111.111.111.111
ftp                      IN CNAME   www
loopback                 IN CNAME   localhost
mail                     IN CNAME   @
relay                    IN CNAME   www
@                        IN MX 10   ALT1.ASPMX.L.GOOGLE.COM.
@                        IN MX 10   ASPMX3.GOOGLEMAIL.COM.
@                        IN MX 10   ASPMX2.GOOGLEMAIL.COM.
@                        IN MX 10   ASPMX.L.GOOGLE.COM.
@                        IN MX 10   ALT2.ASPMX.L.GOOGLE.COM.

I hope someone can figure out, what's wrong with this configuration. When I start a ping on mail.mydomain.org I get an answer from 111.111.111.111 and not from the google server ALT1.ASPMX.L.GOOGLE.COM.

thx, tux

share|improve this question

migrated from stackoverflow.com Jan 17 '11 at 14:20

This question came from our site for professional and enthusiast programmers.

    
Did you give it time to propogate the DNS changes? Sometimes it can take up to 24 hours. –  jmort253 Jan 17 '11 at 11:07
    
Bah! DNS doesn't propagate. –  joeqwerty Jul 1 '11 at 3:36

3 Answers 3

mail.mydomain.org will have to be defined in the DNS system somewhere.

With your current setup, any service looking for the email exchange service ('MX') for your domain, will first try the MX string with the lowest value, i.e.:

MX 10   ALT1.ASPMX.L.GOOGLE.COM

In other words: you either don't need to worry about having a 'mail.mydomain.org', or you have to define 'mail.mydomain.org' in your DNS settings

Also, to investigate the MX setup of a domain.com, you can do:

nslookup -type=MX domain.com
share|improve this answer

Are you sure you're checking the MX records? Try an MX lookup tool like this:

http://www.mxtoolbox.com/

Also, shouldn't your mail CNAME record point to ghs.google.com?

If you don't want to use mxtoolbox you can use nslookup:

Go to a command prompt and type "CMD"

and press enter

Type "NSLOOKUP" and press enter Type "set type=mx"

press enter

share|improve this answer

mail.mydomain.com isn't an MX record for your domain.

mail.mydomain.com is a CNAME (alias) for example.com, which is a synthesised &ORIGIN for your domain based on the @ symbol replacement you've created for the A record.

If you want to verify your MX records then you should perform an MX record test using dig or nslookup.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.