Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a big problem with postfix. I can receive mail in webmin and outlook but I can't send (only on local I can - user to user). Dovecot is working just fine. Sendmail is disable. Please help me.

postfix -n
postfix: invalid option -- n
postfix: fatal: usage: postfix [-c config_dir] [-Dv] command
[root@xprivatecams usr]# postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
home_mailbox = Maildir/
html_directory = no
inet_interfaces = all
mail_owner = postfix
mailbox_command =
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
milter_default_action = acceptsmtpd_tls_auth_only = no
milter_protocol = 2
mydestination = $myhostname, localhost.$mydomain, localhost
myhostname = xprivatecams.com
mynetworks = 94.177.41.0/24, 127.0.0.0/8
newaliases_path = /usr/bin/newaliases.postfix
non_smtpd_milters = inet:localhost:20207
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
sample_directory = /usr/share/doc/postfix-2.3.3/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtp_tls_note_starttls_offer = yes
smtp_use_tls = yes
smtpd_milters = inet:localhost:20207
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
unknown_local_recipient_reject_code = 550

Jan 18 00:46:17 xprivatecams postfix/postfix-script: starting the Postfix mail system
Jan 18 00:46:17 xprivatecams postfix/master[15545]: daemon started -- version 2.3.3, configuration /etc/postfix
Jan 18 00:48:00 xprivatecams postfix/pickup[15546]: EDE7EA8001B: uid=0 from=<xprivatecams@xprivatecams.com>
Jan 18 00:48:00 xprivatecams postfix/cleanup[15817]: EDE7EA8001B: message-id=<1295304480.15812@xprivatecams.com>
Jan 18 00:48:00 xprivatecams opendkim[2776]: EDE7EA8001B: DKIM-Signature header added
Jan 18 00:48:01 xprivatecams postfix/qmgr[15547]: EDE7EA8001B: from=<xprivatecams@xprivatecams.com>, size=615, nrcpt=1 (queue active)
Jan 18 00:48:31 xprivatecams postfix/smtp[15820]: connect to mail.flabell.com[72.47.224.75]: Connection timed out (port 25)
Jan 18 00:48:31 xprivatecams postfix/smtp[15820]: EDE7EA8001B: to=<office@flabell.com>, relay=none, delay=30, delays=0.08/0.03/30/0, dsn=4.4.1, status=deferred (connect to mail.flabell.com[72.47.224.75]: Connection timed out)


telnet 94.177.41.70 25
Trying 94.177.41.70...
Connected to xprivatecams.com (94.177.41.70).
Escape character is '^]'.
220 xprivatecams.com ESMTP Postfix
ehlo me
250-xprivatecams.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
share|improve this question
    
hy, thanks for your answer. [root@xprivatecams ~]# tcptraceroute mail.flabell.com 25 traceroute to mail.flabell.com (72.47.224.75), 30 hops max, 25 byte packets 1 225.40.177.94.is.netvisiontelecom.ro (94.177.40.225) 0.632 ms 0.827 ms 0. 795 ms 2 vl13-border1-nx-buh.netvisontelecom.ro (89.47.225.37) 15.173 ms 15.150 ms 15.109 ms 3 67.17.193.173 (67.17.193.173) 15.281 ms 15.395 ms 15.463 ms 4 po3- –  Catalin Jan 18 '11 at 13:01
add comment

3 Answers 3

Jan 18 00:48:31 xprivatecams postfix/smtp[15820]: connect to mail.flabell.com[72.47.224.75]: Connection timed out (port 25)

Postfix was unable to connect to the destination mail server.

This means either that something in the path between your mail server and theirs is blocking this traffic, or that mail server doesn't actually listen on port 25.

Since I can telnet to it fine, your traffic is being blocked.

Contact your ISP for details.

share|improve this answer
add comment

Does your provider block outgoing TCP to port 25? This line is suspicious:

Jan 18 00:48:31 xprivatecams postfix/smtp[15820]: connect to mail.flabell.com[72.47.224.75]: Connection timed out (port 25)

If you have tcptraceroute installed, the output of "tcptraceroute mail.flabell.com 25" might be useful.

share|improve this answer
add comment

Your conf seems fine, I also think of a port filter problem. What do you get if you try, for example, "telnet smtp.free.fr 25" ?

share|improve this answer
    
[root@xprivatecams ~]# telnet smtp.free.fr 25 Trying 212.27.48.4... telnet: connect to address 212.27.48.4: Connection timed out telnet: Unable to connect to remote host: Connection timed out –  Catalin Jan 18 '11 at 17:36
    
I asked my ISP, they don't block port 25. so this is not the problem. OK - 94.177.41.70 resolves to 70.41.177.94.netvisiontelecom.ro Warning - Reverse DNS does not match SMTP Banner 0 seconds - Good on Connection time Not an open relay. 1.201 seconds - Good on Transaction time –  Catalin Jan 18 '11 at 17:37
    
Ok, so your problem is here (this SMTP server answers properly) : you are filtered on 25/tcp outgoing connections. You may request your ISP why ! Or maybe you have iptables rules set on your server ? –  klipz Jan 18 '11 at 17:38
    
10 open ports: 21 ftp Success 187 ms 22 ssh Success 187 ms 25 smtp Success 172 ms 53 dns Success 172 ms 80 http Success 172 ms 110 pop3 Success 187 ms 143 imap Success 187 ms 443 https Success 172 ms 3306 my sql Success 172 ms 8080 webcache Success 187 ms –  Catalin Jan 18 '11 at 17:38
    
I have disable my firewall. So I don't have an iptables rule, no ? –  Catalin Jan 18 '11 at 17:46
show 8 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.