Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

how disable this header ? googled ,no reply; X-Mod-Pagespeed: 0.9.14.6-358

I attempt: RequestHeader unset X-Mod-Pagespeed

It's does nothing

share|improve this question
add comment

3 Answers

It's generated because mod_pagespeed for apache is installed and enabled in your apache server. On ubuntu/debian you can disable it easily by doing:

"a2dismod pagespeed" 

You can check the exact name of the module launching a2dismod without argument. The other way is to go to your apache config folder and remove the pagespeed symlink in mods-enabled.

Don't forget to restart apache through "/etc/init.d/apacche2 restart".

share|improve this answer
    
All these methods disable pagespeed - but its probably there for a reason. –  symcbean Jan 18 '11 at 11:35
    
Right sir, I didn't pay attentionto the details, mea culpa –  Shadok Jan 18 '11 at 13:01
add comment

You'll need to edit the source code for mod_pagespeed and recompile - look for a line starting with something like.....

apr_table_add(request->headers_out, "X-Mod-Pagespeed"....
share|improve this answer
    
ended up just killing the header by reverse proxying nginx –  prakesh Jan 18 '11 at 19:09
add comment

It's a response header, not a request header -- so just use Header unset not RequestHeader.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.