Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When i go to /index/test i get /index.php/test. I would like to be able to mod rewrite from /index/page1 to /index.php?page=1 but even without any .htaccess file i get the index file without the variale.

It seems that my server is set to guess the extension and get the file if it exists. Is a Mac os X Server 10.6 with standard configuration (apache2).

Any ideas?

share|improve this question

2 Answers 2

I found that multiviews was set by default in /etc/apache2/sites/0001_any_80_[mydomain].conf

Just change +MultiViews to -MultiViews in:

Options All -Includes -ExecCGI -Indexes +MultiViews

share|improve this answer

There is an extension called mod_spelling that could also be the culprit

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.