Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem writing to a folder that I share using samba on my ubuntu machine. I can access the files from my Windows 7 machine, but I cannot write to the folder, any suggestions?

Thank You very much

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Samba executes the file operations as a local unix user on the server you are running samba on. Make sure that you have this user defined to the one you want in smb.conf and that this user has write access to the directory/files.

you can see the full example here

but basically what you want to do is:

[someshare]
comment = Some Share
path = /path/to/share
read only = No
force user = someuser
force group = somegroup
guest ok = Yes
create mask = 0775

then you just need to do:

chown -R someuser:somegroup /path/to/share
chmod -R 775 /path/to/share
share|improve this answer
    
Thank you, I was able to use a nice application sadms that is in the ubuntu software center to accomplish what you suggested. –  Chris Jan 19 '11 at 1:13

Check those two things first:

  • make sure the checkbox "Allow others to create and delete files in this folder" in the properties of your shared folder is checked OR

  • make sure to use a known user account on the ubuntu machine to access the share

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.