Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So, I pulled an absolutely amateur move and worked for twelve hours yesterday on a test installation on Amazon AWS/EC2. Full Drupal project nearly completed in one day, but, I screwed up ROYALLY.

In the beginning of the day I "sudo passwd ubuntu" and set a password for user ubuntu (the default login for Amazon EC2 ubuntu boxes). Normally this is where you would modify the /etc/ssh/sshd_config and set "PasswordAuthentication" to YES, then restart the ssh service, thus allowing yourself to login with a password in addition to your keys.

Unfortunately for me I somehow completely forgot to edit the sshd_config and now whenever I attempt to login to the instance I get an error from putty that reads "No supported authentication methods available"

Does anyone, anywhere, have a resolution for me besides "migrate your entire project and don't do that again, cause you're screwed?"

Thanks guys, most appreciated

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Is the code you need to get at mounted on an EBS? You can unmount it, and mount it to another instance I believe to get at the code.

EC2 Detach

share|improve this answer
    
That's a good approach, and if I wasn't even MORE retarded than originally thought, that probably would have worked. –  Todd Shaffer Jan 18 '11 at 22:48
add comment

I wasted a lot of time today when the simple answer was in front of me. PuTTy lost my pem key somehow, and all I had to do was re-assign it and I was able to connect immediately.

DOH!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.