Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an old rack-mount (4u) server which booted from the network (with PXE) when it was in use. I was aiming to install debian or wot not on the hard drives (it has 5), so I tried wireshark and a DHCP server on another box. The server sent out DHCP discovers, but it wouldn't respond to DHCP offers from my box. Guess it was waiting for a specific MAC? Meh. Anyway, I couldn't get to the BIOS configuration by mashing F2 (it showed "Entering Setup..." and then just kept going with the boot), and the PXE setup menu was unhelpful. I have a "bios cd" which I suspect has the config utility files on it, but that's where my trouble started.

The box was flaky from the start...sometimes it showed VGA output, sometimes not. Sometimes, especially on resets, it didn't even boot up and I would have to pull the pug out. It seemed the only times it worked were when I had physically just put the plug in (after pulling it when it was running). When I put the bios CD in I believe was right after the last time it went up correctly. After putting the disk in (it has a CD drive for whatever reason) and booting it up, it just wouldn't go. The fans started up and made their usual jet takeoff noise, but no VGA output and after waiting for quite some time no DHCP discovers. Taking the disk out and repeating (many times) has not yielded any more success. I have not tried resetting the CMOS.

This machine isn't vital to anything, but it was given to me and it would be nice to see it working. I have a brief hardware spec which I can give excerpts from on request. It's a dual-processor (pretty neat; separate dies, fans, and heatsinks) Opteron with SCSI disks and four on a hardware RAID controller. The first BIOS that pops up on boot is American Megatrends. It came out of an MRI machine during upgrades and did signal processing (furrier transform mostly) on sensor data. It has no visible branding inside or out.

EDIT: I had it running for maybe 1/2 hour, turned off the display, and it beeped the PC speaker. I turned the display back on and saw the PXE starting up and saying Ctrl+S for configuration. WTF? To learn from this, I will note that the PXE is "Broadcom NetXtreme Ethernet Boot Agent v7.0.3", Copyright 2003. Any ideas on what to conclude from this?

EDIT 2: After another unplug/plug cycle, I saw the boot from the start and things appear normal. No idea what's going on now. The next step is getting it to boot an actual OS. Can anyone shed some light on the problems mentioned in the first paragraph?

EDIT 3: It's bricked again. It just can't decide whether it's alive or not... I'm going to open it up and boot it that way to see if anything is obviously wrong. Can anyone explain this strangeness? Never had something like this going on before...

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

Well, you guys are never going to guess what it was...

I had plugged a working PS/2 keyboard into the jack at some point during my testing and thought nothing of it. It's a keyboard plugged where it's supposed to go, what harm could it do, right? Well, I unplug it, and everything works fine. Weirdest thing I've seen in a while.

I'd be interested in knowing why it did this...

share|improve this answer
2  
I wonder if it was a PS2 port for the server, or instead it was on a remote management card? –  mfinni Jan 31 '11 at 21:15
add comment

It could be several things. Problems like this are notoriously hard to track down because the problem falls in the category of "not working with no real information". Because it started working suddenly, my guess would be either so much dust on the inside of the machine it was overheating, or alternately, a short because of some metallic shard of something somewhere on the motherboard that finally got blown away by the server fans. This is especially possible since it was in the same room as an MRI machine which would do all sorts of fun stuff with any tiny dust-particle sizes of metal around.

It could also be, in no particular order:

  • Problems with the BIOS upgrade
  • Connection loose somewhere in the system
  • Blown caps
  • Badly seated memory

Since it's not even POSTing properly, I'd look at hardware problems first. Crack it open and dust out the inside, reseat the RAM. If you're feeling adventurous, /carefully/ pull the CPUs and put new gel on the heatsinks as well as blowing dust away from the sockets. Hopefully that will cause it to start working again. Good luck!

share|improve this answer
1  
+1 also, I'd be looking at the PSU(s) and/or power cable (maybe try another one?) –  gravyface Jan 19 '11 at 3:18
    
Gravyface has a good point - it could be a problem with the PSU. The power cable I think is a little less likely if the machine is getting enough power to operate the fans, but if the PSU isn't working properly, the fans could be getting power and other parts of the system could not be. –  Scrivener Jan 19 '11 at 4:18
    
There's hardly any dust inside it...I opened it up to start with and was surprised quite a bit at the lack of anything in there. The memory (all 8 sticks :O) appears to be fine. –  marcusw Jan 19 '11 at 22:08
add comment

You mentioned putting in a BIOS CD. Are you trying to update the BIOS? If so it could be a problem with the version you are trying to update to? My guess is the backup BIOS is kicking in. Something wrong with the main BIOS.

share|improve this answer
    
I couldn't care less about BIOS updates, I just want this thing to boot up. I need to get into the BIOS menu to get it to boot from a CD. Alternatively, I could take out the HDD and put something on it, but that's a bit nasty. –  marcusw Jan 19 '11 at 22:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.