Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have this issue, I have a W2K8 Server in which I'd like to establish a VPN Connection for a small group of Users (like 7 or 8).

Heres some information about the server obtained by using cmd > ipconfig /all this is dummy info by the way but I'll substitute back to make the modifications:

Overal Information

  • Server name: MyServer
  • Share Name: \\MyServer\TheShare
  • *

Windows IP

  • Host name: HST-SVR-08
  • Node Type: Hybrid
  • IP Routing enabled: yes
  • WINS Proxy: no

Ethernet Adapter

  • IPv4 Address(Public as shown in whatsmyip): 206.180.190.10
  • Default gateway: 206.180.190.9 (its different from the IP by one numbers in the last octet)
  • DHCP Enabled: no
  • Subnet Mask: 255.255.255.253
  • DNS Servers: 208.163.41.17, 208.163.41.15 (yes they only differ in the last number also)
  • NetBios over Tcpip: enabled


I have done the following:

On the Server

  • Created a group called Remote and added the users to it.
  • Created a share and granted read/write permissions to the group Remote.
  • In Control Panel > Network Connections > File > New Incomming Connection a new incoming connection with the appropriate users and in the networking tab I have IPv4, QoS and File and Printer Sharing checked (IPv6 is disabled.).
  • In Server Manager > Configuration > Firewall with Advanced Settings both for inbound and outbound I enabled the rules for File and printer sharing(SMB-In/Out), as well as Routing and Remote Access (GRE-In/Out)(L2TP-In/Out)(PPTP-In/Out).

On the Client

  • Control Panel > Network and Sharing Center > Connect to a workplace > Use My internet connection (VPN) In the Address field: \\< server-IPv4 >\TheShare, in the Destination name field: VPN Test then on the next screen I entered the appropriate credentials for a user and left the domain field blank.

And got this message:

Windows cannot find the hostname "\\TheShare" using DNS the domain name server may be down.

  • Tried also mapping a drive to it Computer > Map network drive and entered the same in address field: \\TheShare and got this message:

    "< server-IPv4 >" is not setup to establish a connection on port file and printer sharing(SMB) with this computer.

Which is weird because I opened the ports on the windows firewall.

This only happens when connection over the internet as when I try a VPN Connection in the LAN it works flawlesly I can also map a drive in the LAN.

Any Help is really appreciated.

share|improve this question

1 Answer 1

You need to read the documentation and wikipedia about what a VPN is.

Control Panel > Network and Sharing Center > Connect to a workplace > Use My internet connection (VPN) In the Address field: \\< server-IPv4

\TheShare,

Ok, so instead of an address you give a UNC path to a share. Zero sense.

Also you don't show how you configure RRAS, the VPN server. You have an odd mixture of configuring a file share and then saying it is a VPN, then trying to use the VPN client to connect to a file share. Lots of technologies and things put into a mixer expecting something sensible to come out.

  • If it is VPN, scrap all the share stuff. You dont need a share.

  • Then, naturally, on the client you give the server name / ip address. Not "in a UNC form pointing to a share". Instead of "\\ipv4\share" it is "ipv4".

  • On the server you need to install a VPN server. RRAS (Routing and REMOTE ACCESS is what you want from the server features.

Once the VPN is established, the server is part of the network and you can maccess files normally.

share|improve this answer
    
Thanks by the reply, you were right about the UNC, I entered only the IPv4 address and I connected successfully, however the server does not appear in Network nor I can access any of the files. I have the RRAS service enabled and the firewall port open. –  Triztian Jan 19 '11 at 6:54
    
For the server to appear in network you need more enabled. Does the server actualyl show up? Normally they do not - you need to configure that, too. –  TomTom Jan 19 '11 at 9:57
    
Connect by name (there is a menu item to connect network drive, takes theunc path, plus there is a command line command to conenct to a network drive). –  TomTom Jan 19 '11 at 9:57
    
Sorry for the late reply, No, the server doesn't even show up, where do I configure that?, also I believe the command is net use \\server\share –  Triztian Jan 19 '11 at 16:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.