Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I own a rackspace cloud server which worked fine. I used WinSCP and Putty to connect to it and manage it. Then I re-sized the instance adding some more memory. Now whenever I try connecting to it through putty it accepts the username but even for the correct password it returns "Access Denied".

There is nothing wrong with my putty settings because I can connect to my other Raskspace Cloud servers. Its not working only for this instance.

I restarted ssh several times, regenerated the keys, reinstalled ssh and openssh-server and so one bu no avail.

share|improve this question
    
@lynxman is right — please contact Rackspace Cloud Support via Live Chat or by calling 1-877-934-0407. You can also contact me via email: robot AT rackspace DOT com. ~ Robert Taylor, Sr Sys Engineer, Rackspace Hosting. –  rjamestaylor Jan 19 '11 at 15:03

2 Answers 2

This looks like a corrupted file on your server, possibly as a product of this server resize, if I were you I would contact Rackspace support and ask them to have a look.

share|improve this answer

I ran the following commands

sudo apt-get remove ssh
sudo apt-get remove openssh-server

rm -rf /etc/ssh 
mkdir /etc/ssh
sudo apt-get install ssh openssh-server

And bingo it worked.

share|improve this answer
    
So looks like I was right, happy to see it worked :) –  lynxman Jan 20 '11 at 8:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.