Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having a problem with a particular port on my web server.

It's Windows 2008 and running IIS7.

When I try to navigate to this particular port, I get an Internal Server Error - 500.

I've checked the Event Viewer, and the following error messages are shown:

  1. ‘The HTTP Filter DLL C:\Program Files (x86)\PHP\php5isapi.dll failed to load. The data is the error’

  2. ‘Could not load all ISAPI filters for site ‘example’. Therefore site startup aborted.’

I'm not familiar with servers at all at all but at the moment there's no one really to fix it. Could anyone point me in the right direction?

share|improve this question
"I'm not familiar with servers at all " I think that should be reason enough for you to back down, and hire a professional. – Tom O'Connor Dec 19 '11 at 11:45
Well Tom if I had my way I would never touch the stuff but unfortunately circumstances didn't allow for that at the time and I'm not the one in charge so I had to ask the question. That's what this site is for isn't it? So rather than leaving sarcastic comments (almost a year after the question was posted too) that don't help anyone why don't you so outside and be a sarcastic jerk to real people and see how long that lasts. – 109221793 Dec 19 '11 at 11:55
up vote 1 down vote accepted

If you're seeing a "Filter XYZ.DLL failed to load from (path that implies 32/64-bitness)", try toggling the App Pool's bitness first, in the "Enable 32 Bit App" property setting.

There's File System and Registry redirection which makes life trickier for Sysadmins (though no trickier for app developers, so it's a mixed blessing) on 64-bit Windows platforms, and it causes paths to get translated to different locations for different bitness-es.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.