Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed qemu-0.13.0 on x86 system. I downloaded debian-powerpc image from http://people.debian.org/~aurel32/qemu/powerpc/ and used it with this command

$qemu-system-ppc -hda debian_lenny_powerpc_small.qcow2 -nographic

This is the cpuinfo of the guest os (debian-507-powerpc (2.6.26-1-powerpc) )

processor    : 0
cpu        : 740/750
temperature     : 62-64 C (uncalibrated)
clock        : 1000.000000MHz
revision    : 3.1 (pvr 0008 0301)
bogomips    : 33.02
timebase    : 16600733
platform    : PowerMac
model        : Power Macintosh
machine        : Power Macintosh
motherboard    : AAPL,PowerMac G3 MacRISC
detected as    : 49 (PowerMac G3 (Silk))
pmac flags    : 00000000
pmac-generation    : OldWorld

After that, I installed qemu-0.13.0 on that guest os , and tried to run the same debian-powerpc image on it.

$qemu-system-ppc -hda debian_lenny_powerpc_small.qcow2 -nographic

The boot process got stuck with this:

>> =============================================================
>> OpenBIOS 1.0 [Dec 6 2009 11:39]
>> Configuration device id QEMU version 1 machine id 2
>> CPUs: 1
>> Memory: 128M
>> UUID: 00000000-0000-0000-0000-000000000000
>> CPU type PowerPC,750
Welcome to OpenBIOS v1.0 built on Dec 6 2009 11:39

Second-stage QUIK loader
Welcome to quik. mate is good.
Debian GNU/Linux PowerPCchosen/bootargs = Linux
boot: Linux 
initrd imagename = /initrd.img, mem_size: 7168568
initrd_start: 
Starting at 510000, , 13004800
OF stdout device is: /pci@80000000/mac-io@4/escc@13000/ch-b@13000
Preparing to boot Linux version 2.6.37-rc6+ (user@user) (gcc version 3.4.5) #1 Tue Jan 11 22:10:00 IST 2011
command line: root=/dev/hda3 ro 
memory layout at init:
  memory_limit : 00000000 (16 MB aligned)
  alloc_bottom : 00ea3000
  alloc_top    : 08000000
  alloc_top_hi : 08000000
  rmo_top      : 08000000
  ram_top      : 08000000
found display   : /pci@80000000/QEMU,VGA@1, opening... done
copying OF device tree...
Building dt strings...
Building dt structure...
Device tree strings 0x00ea4000 -> 0x00ea43b0
Device tree struct  0x00ea5000 -> 0x00ea7000
Calling quiesce...
returning from prom_init

Thanks,

share|improve this question
    
VM in a VM on a host is pretty much completely unsupported and I'm having a hard time imagining why you would want to do this. Have you checked with the QEmu people to see if they're aware of a good reason this will not work? –  Chris S Jan 19 '11 at 13:27
    
Qemu uses Binary Translation to provide virtualization so, its basically software virtualization. And so, I think it should not be a problem to run qemu over qemu. –  db42 Jan 19 '11 at 13:31
add comment

1 Answer

When you use -nographic you cannot see the boot progress.

It usually takes a very long time from "returning from prom_init" to "Debian GNU/Linux 6.0 debian-powerpc ttyPZ0".

share|improve this answer
    
This would be verifiable by looking at the CPU usage, if the outer qemu does not already eat it up. –  Adrian Lang Nov 22 '12 at 16:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.