Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am not able to ping a couple machines within our network from our WinServer 2008 machine by IP. I am able to ping them by name though. So, it appears IPv4 pings are failing and IPv6 are succeeding.

To make a simple example, I'll choose one of our machines which is running Windows 7 pro and has both IPv4 and IPv6 enabled on the adapter. It has a static IP, is able to talk to the server that can't ping it by IP, is connected to a share on the same server, etc.

I would appreciate any thoughts or suggestions on how to resolve this so I will be able to RDC into these machines.

I should note that the server is using Windows Firewall and I tried turning the firewall off completely and I still wasn't able to ping or RDC to the Win7 machine.

share|improve this question
if you use the command "Ping servername -4" what reply do you get? –  Sam Jan 19 '11 at 20:23
Thank you for your reply Sam. This is odd..now it isn't timing out any longer and is returning the IP. The result you asked for is: Reply from bytes=32 time=3ms TTL=127 Before, it was timing out. I can now ping via IP and name both. RDC still is not authenticating, but I should open a separate thread for that issue. –  Russ Jan 19 '11 at 20:41
@Russ My first impression was that you had enabled ICMP echo traffic ("pings") for IPv6 and NOT IPv4. If it happens that way with WF. Turned off, it might be configured that way on your network. Perhaps talk to your network administrator? Before you do that, two questions: 1) are you using some AV program (Symantec specifically Endpoint protection is notorious for such weird problems) and 2) how did you turn off the firewall exactly? The old-fashioned way obfuscates a lot of goodies in the new Advanced Windows Firewall (check it out from secpol.msc). –  ajstein Jan 19 '11 at 20:43
Hi Alharaka and thanks for your reply. –  Russ Jan 19 '11 at 20:52
Hi Alharaka and thanks for your reply. I'm not sure what made the pings work now, but they are working. To answer your questions, yes we are using VIPRE antivirus. How I disabled the firewall was by logging into the server via RDC, going to Windows Firewall & Adv Security->Overview->Windows firewall properties. From there, I set the firewall state to 'Off' for the Domain and Private profiles. I renabled them after testing the pings. Interestingly, looking at the Local Security Policy via secpol.msc, it says that windows firewall states are not configured. –  Russ Jan 19 '11 at 21:00
show 1 more comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.