Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So here is my problem, I'm absolutely unable to connect to a FTP server, in circumstances I've never seen before. Here is the situation :

  • I get a "Connection timed out" just after the MLSD command.
  • I usually use Filezilla, under Ubuntu, but to make sure the problem isn't related to this particular client I tried a few others : gftp on ubuntu and winscp and freeftp on windows 7. All the same result.
  • Also made sure to try with Active or Passive modes. Same result.
  • At this point I would be inclined to think there is something wrong with my current network (furthermore, according to a coworker the FTP server is OK). But I did check with http://ftptest.net/ and I am able to get the directory listing (which I'm not able to through a FTP client).

So in the end the last thing I didn't tried is to go on another network, solution which seems would work, but wouldn't be very practical in the long run. And thus I guess there's something wrong with my router... but what could it possibly be?

Note : I did try to register and post this question on filezilla's board first... but I can't create an account with a gmail nor hotmail account. WTF?

share|improve this question
    
For information, we also had the MLSD command problem, but this was not a firewall issue, but too many files in the directory (more than 40 000). –  Marc MAURICE Apr 22 '13 at 15:29
    
I had this problem too. Strangely, the issue resolved after I added the server configuration to the Site Manager and set UNIX as server type. –  Emiswelt May 30 at 3:34
add comment

4 Answers

I fixed the problem by using a ssh tunnel through one of my personal server. I am absolutely stumped as to why this would work. I'm currently in Japan, and my server in Canada, so perhaps there is an issue with IPv6 address (even though the server says it shouldn't)...?

share|improve this answer
add comment

According to the FileZilla admins, your router is probably the issue (even though you probably can't do anything about it), and they're not going to fix it to fall back to LIST if MLSD times out. See: http://forum.filezilla-project.org/viewtopic.php?f=2&t=11405&start=15

Solution: Try Core FTP or similar. It's unlikely you'll be able to convince the stubborn FileZilla folks to add a (stupidly simple) workaround option- "fall back to LIST if MLSD times out".

Or, since it's open source, see if you or someone else can make the change and compile it yourself. I imagine if you try to submit the change to be added to the official build, they'll reject it, but perhaps we could be pleasantly surprised.

share|improve this answer
add comment

Just want to let people know how I got this working.

With the MLSD timeout the problem can also be in the router.

I got a new Asus router and I forwarded the ports for passive mode wrong. I have a qnap NAS and I connect on port 21 on ftp and port xxxxx:xxxxx in passive mode. In my asus router I set the port forward (virtual server) correctly now and it works again. My FTP is forwarded correctly on port 21 to my NAS IP, just standart stuff. The problem was the passive ports my NAS wanted to use also.

I did this in my port forward section (Virtual Server is it called in ASUS routers):

Service name: Whateveryoulike

Port Range: The passive ports your device will use (standart 55536:56559 for Qnap)

Local IP: The local IP of the device (something like 192.168.0.xxx)

Local Port: LEAVE THIS BLANK

Protocol: Both

Add

Apply

BOOM! We got uplink.

The problem could be something else, but this fixed my timeout and now it all works.

share|improve this answer
add comment

After a long search, the solution is simple:

Go to site management, choose the site with the problem. Choose tab "Transfer Settings" and select "active instead of 'default'.

share|improve this answer
    
Luckily I know dutch but could you please post in English? –  timmeyh Mar 28 '13 at 8:58
1  
@timmeyh would you mind translating and post it as a comment and then I'll edit it in. –  tombull89 Mar 28 '13 at 9:19
    
This solution worked for me. –  Martin Metsalu Nov 25 '13 at 15:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.