Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm a programmer who is tasked with handling server support until we can hire a new sysadmin, so bear with me. I'm having a problem, where the DNS records for computer names don't resolve to the correct IP.

For example computer name RODSCOMPUTER's actual IP address (from DHCP in Server 2008 R2, also confirmed on ipconfig) is 192.168.1.111 however when I go on another machine and ping RODSCOMPUTER it resolves to 192.168.1.149. Also when I go to the DNS management console in Server 2008 R2 it shows up as the wrong value.

I take it it's expired, but DNS hasn't caught up - how do I make this stay accurate? It's vital for us in our network as we remote desktop frequently.

share|improve this question
add comment

2 Answers

For a quick fix, try running this on the client computer:

ipconfig /registerdns

This should update the DNS record for this client.

Also, you might want to take a look at this document which explains how to configure Dynamic DNS Updates on Windows Server 2003 (We don't have Server 2008 R2, so I can't tell if it applies to you - but I don't think it will be all too different).

http://support.microsoft.com/kb/816592

share|improve this answer
    
I tried running the /registerdns and it did not work, also the problem is network wide and I don't really want to run that on the pcs, I also looked in DHCP settings and automatically update DNS settings are all fine –  RodH257 Jan 20 '11 at 23:17
    
I am not sure - have you checked the configuration of your DNS server? It should be set to allow Dynamic Updates. See here: support.microsoft.com/kb/816592#51 Also, check the settings of your DHCP server: support.microsoft.com/kb/816592#96 Have you checked DNS and DHCP server logs? DNS log is found in Eventvwr -> Applications and Services Logs -> DNS Server. DHCP Server log -> Management Console -> DHCP Server -> Right click IPv4 / IPv6 Address Range -> Tab Advanced -> "Audit log file path" -> this gives you the path to the DHCP server log files. –  sa_zh Jan 21 '11 at 8:14
add comment

the command is ipconfig /flushdns not /registerdns You need to to clear the dns cache first so then you can query the DNS server directly. On MS windows, the order of operation for DNS is : 1. hostfile 2. dns cache 3. dns server

You have this issue because 3 reasons: 1.Your TTL time for the records are to big. make them smaller like 5-12 hours. 2.You are allowing Dynamic Updates 3.Your DHCP lease time is to small

DNS TTL tels the client how long the record is valid. Based on this value its cache in the local dns cache.

Dynamic Updates: Every time you serve DHCP, the windows client updates its record in DNS (you can mitigate the Dynamic Updates if you chose register dns and append suffixes in the Network Connection of the Adapter on the workstation)

I figured that you DHCP lease time is to small by the fact that you have so many changes in the DNS that would cause problems.

Here is a good article for you:

http://support.microsoft.com/kb/297510

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.