Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I try to connect to my IIS website using Dreamweaver. Checking the 'use passive ftp' I manage to connect, unchecking results in a timeout and error. Until here it's all right. Now I want to use another client (the fpt explorer plugin of CFeclipse ide, for those who know) but it doesn't connect. Same address, credentials, I looked at all stupid settings. Googling a little brought me to this question. That plugin does not have a passive ftp option so, can I enable the active ftp to do a workaround?

Thanks

share|improve this question
    
Active vs/passive is usually set on the client. Is there a NAT between the client and server? Passive ftp works better through some firewalls. Have you tried temporarily disabling any host-based firewalls to be sure it isn't a firewall issue? –  Zoredache Jan 20 '11 at 8:41
    
There seems to be a passive mode checkbox in this screenshot. boyzoid.com/images/ftp_eclipse/step2.jpg Am I looking at the wrong guide? –  Zoredache Jan 20 '11 at 8:48

1 Answer 1

IIS supports both Active and Passive FTP connections by default. You don't have to do anything special to enable either one. You also can't disable either one as far as I know. You can however, configure the port range that IIS will use for Passive FTP sessions, but that won't help you here. The problem is most likely that your firewall doesn't support or isn't configured to allow Active mode FTP sessions, so your options are to find and enable the Passive mode FTP settings in your application or configure your firewall to allow Active mode FTP sessions.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.