Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've tried recreating the RAID, but every time I get to the section of the installation where it asks which hard drive to use, it claims there are none available.

I currently have two 300GB Seagate Cheetah 15.7k drives in RAID1. It is brand new.

Thanks

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

So you're going to hate this but I'm willing to bet that you are using either the H200 or H700 raid cards. These aren't really cards so much as some software on the motherboard that interfaces with Windows. They fail to mention that they are completely unsupported in Linux.

share|improve this answer
    
Oh shit! It is the H200 raid card! I guess I'll be googling workarounds. Anybody happen to know if it's possible? –  Luke Jan 20 '11 at 16:17
1  
We ended up having to purchase the PERC6 raid controller from Dell. It was very easy to swap the connections over to it. Some quick googling led me to this: support.dell.com/support/systemsinfo/… which suggest that RHEL is supported. CentOS being a clone of that... So you might be able to get it too work. I'll look a bit more –  TrueDuality Jan 20 '11 at 16:25
    
Mark your question as answered! FYI, you will run into the same thing with ESXi –  SpacemanSpiff Jan 20 '11 at 16:44
    
Before spending money on hardware, try Linux software RAID. It's quite fast in non-parity RAID levels. –  Aaron Copley Jan 20 '11 at 17:06
    
The problem is that the individual drives won't show up at all with this RAID controller installed. Software RAID wouldn't be an option unfortunately. –  TrueDuality Jan 20 '11 at 17:11
show 1 more comment

Could be one of two things.

a. Your RAID controller is not supported.
b. Misconfiguration.

share|improve this answer
add comment

Shouldn't you be installing a newer version of CentOS? 5.5 perhaps?

share|improve this answer
    
I wish that was the way the world worked. –  Luke Jan 20 '11 at 18:06
add comment

Cheap or 'software' RAID setups often need a special driver (to offload RAID calculations onto the CPU, like the good old winmodems) to function.

You will have to turn of your Dell RAID and use Centos's built-in 'software' RAID capabilities (RAID 1 is ideal for this anyway), or upgrade to a proper RAID card (i.e. with a CPU on it, RAM module(s) and a battery backup unit)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.