Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Ubuntu Server (10.10) running. There are two server components active: The fileserver is Samba and OpenSSH for remote access. It is a home network, (workgroup).

When I use OpenSSH from windows, the servername can be used instead of an Ip (servername.local)

When I ping servername.local from windows, the IP is resolved.

When I try to connect to a Samba share from Windows (win7) I need to supply the ip address. I can't use the computername. Is it possible to configure this in a way that I can use computername instead?

Thanks, Sander

share|improve this question

1 Answer 1

Sounds like Windows 7 doesn't have a NetBIOS client running. Can you run nbstat?

To get this working in a small environment you can use the hosts file for simple name resolution. This is probably the better option rather than trying to get NetBIOS running on Windows 7 (if it is indeed unsupported.) DNS would also be over kill.

Also, please be aware that serverfault is intended for professional system administrators. (serverfault.com/faq) This sort of question relating to a home network is better suited to superuser.com. (superuser.com/faq)

share|improve this answer
    
Thanks. I will use supersuser next time. I can't find nbstat on my win7 at the moment. But adjusting the host file works for now. –  Sander Jan 20 '11 at 16:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.