Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running out of ideas. After a long period of testing this morning, I cannot seem to get this to work, and I have no idea why. I want to mount a Windows SMB/CIFS share with a Debian 5.0.4 VM, and it is not cooperating.

This the command I am using.

debianvm:/home/me# whoami

root

debianvm:/home/me# smbclient --version

Version 3.2.5

debianvm:/home/me# mount -t cifs //hostname.domain.tld/share /mnt/hostname.domain.tld/share --verbose -o user=SUBADDOMAIN.ADDOMAIN.DOMAIN.TLD/username

mount.cifs kernel mount options: unc=//hostname.domain.tld\share,ip=10.212.15.53,domain=SUBADDOMAIN.ADDOMAIN.DOMAIN.TLD,ver=1,rw,user=username,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,pass=*********mount

error 5 = Input/output error Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

debianvm:/home/me#

The word on the nets has not been very specific, and unfortunately it is almost always environment-specific. I receive no authentication errors. I have tried mount -t smbfs and mount -t cifs, along with smbmount and such. I get the same error before. I doubt it is a problem with DNS resolution, because logging shows the correct IP address. dmesg | tail -f no longer shows authentication errors when I format the domain and username accordingly. I have played a little with iocharset=utf8, file_mode, and dir_mode as described here. That did not help either. I have also tried ntlm and ntlmv2 assuming it might be a minimum auth method problem, but not forcing sec=ntlmv2 it can still authenticate without errors anymore. smbclient -L hostname.domain.tld -W SUBADDOMAIN.ADDOMAIN.DOMAIN.TLD -U username correctly lists all the shares and shows it as the following.

    Domain=[SUBADDOMAIN] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]

Sharename       Type      Comment
---------       ----      -------
IPC$            IPC       Remote IPC
ETC$            Disk      Remote Administration
C$              Disk      Remote Administration 
Share           Disk      

Connection to hostname.domain.tld failed (Error NT_STATUS_CONNECTION_REFUSED)
NetBIOS over TCP disabled -- no workgroup available

I find the last line intriguing/alarming. Does anyone have any pointers!? Maybe I misread the effin manual.

share|improve this question
    
Have you tried adding workgroup=workgroupname to the mount command? –  Chida Aug 12 '12 at 13:00
    
Have you tried adding it directly to fstab? //domain.ltd/share /mountpoint/folder cifs username=yourusername,password=yourpassword 0 0 after that executing # mount -a ? –  Str82DHeaD Jan 21 '13 at 19:38
add comment

2 Answers 2

Another approach which solved me my problem:

Try a different sec option. My Debian default reside in /proc/fs/cifs/SecurityFlags is 0x81, (digging in: https://www.kernel.org/doc/readme/fs-cifs-README didnt resolved what the 0x80 mean). Nevertheless after trying some security option, it worked for me with -osec=ntlm.

Worth a shot.

share|improve this answer
add comment

Couple questions that may or may not help:

IS the VM network in bridged or NAT mode?

Can you mount this share from a windows box that is not a member of the domain?

Is there AD security policy preventing this box from authenticating? Anything in the fileserver or DC logs?

share|improve this answer
    
IS the VM network in bridged or NAT mode? Bridged. Can you mount this share from a windows box that is not a member of the domain? Yes, a Windows PE instance running on a laptop behind me. Is there AD security policy preventing this box from authenticating? Anything in the fileserver or DC logs? Alas, I do not have access to such things. I am a lower admin on the totem pole. –  ajstein Jan 20 '11 at 17:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.