Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Coming into the office this morning, I was told that our web server was down. After remoting in, I noticed Server Manager failed to start with an error saying "MMC could not create the snap-in". I tried opening eventvwr and got the exact same error. Then, trying to connect to localhost in IIS Manager, I receive the error "The request is not supported." I'm a developer with little system administration experience, so I've been searching for hours. I've made sure Windows Event Log and Task Scheduler are running in services.msc, I ran sfc which had no errors. I was told there were updates installed last night. Any possible/usual causes for these issues come to mind? Thanks in advance.

share|improve this question

You haven't specified whether this is a production or development server so I'm operating under the assumption that it is a production server.

If I'm incorrect please say!

Updates were installed? How were these updates installed, are you rocking automatic updates for a production server? If you are I suggest you change that setting to download and install manually, many of the headaches I've suffered ahve been caused by unmanaged changes to systems caused by automatic updates.

If you're updating your production boxes at the very least someone should be on a VPN Connection to check that everything comes back following the updates, ideally you should have someone who can touch the box whilst carrying out the patching.

Have you rebooted the server since finding it this morning? If not I would suggest you do that to see if the issue persists or is resolved.

If it persists working on the assumption that the updates are the only changes to your server, your next step should be to uninstall the recently applied updates one at a time until the issue dissappears.

Sometimes patches just apply wonky and other times things that have been done to a server cause patches to break things, once you find the patch that is causing the issue you can decide what course of action to take. Ignore that patch or try to re-apply it.

If you have the ability to do so I would advise setting up a second server to test patches on before they get applied to your web server (You may already have this, but if not its worth saying).

share|improve this answer
Yes it is a production server. Automatic updates are on. I tried rebooting first thing to no avail. I uninstalled every update installed today and restarted, still nothing. Thanks for all the advice so far. – Christopher Garcia Jan 20 '11 at 18:52
Has anything else changed on the server recently? New sites deployed, new software? - any other suspect messages in the Application or System Event Logs? – ITHedgeHog Jan 20 '11 at 19:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.