Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We've installed VMWare Server 2.0 on Windows 2008R2. After some time playing with it (actually only removing host-only and nat networks, and binding adapters to the specified vmnets) we've noticed a strange problem: if you change or remove the default gateway on the network card, the server completely loses a network connection you can't ping it from the subnet, it also can't connect to anyone.

When the gateway is removed and a server tries to connect to the other machines, I can see some incoming packets using a sniffer, but I believe they are damaged in some kind (I'm not a mega-guru in TCP/IP and can't find a mistake in a binary translation of the packet) because the other side doesn't respond.

What we tried:

  • removed vmware server using add/remove programs
  • deleted everything related to the vmware server and all installed network adapters in the windows registry
  • double checked for the vmware bridged protocol driver file, it's physically absent and no any links in the registry.
  • performed a tcp/ip reset with netsh and disabled/enabled all network adapters in the device manager to recreate a registry keys for them.
  • tried another network adapter.

and the situation is the same: as soon you remove or change the default gateway, windows stops working.

The total absurd of the situation is that the default gateway points to the non-existing IP. But when it's set, you can ping a server from the subnet, when you remove it - you can't.

Any help? I'm starting thinking the new build of the VMWare Server is some kind of the malware... :)

share|improve this question

Try this:

open an administrative command prompt and type:

netsh interface ipv4 reset resetlog.txt

this will kick all interfaces back to DHCP and clear their configurations.

share|improve this answer

Try navigating to HKLM\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\Interfaces and deleting the GUID that corresponds to the interface you have set up. Windows will re-create this key with default settings (DHCP). If it doesn't, 'remove' the network card from Device Manager then scan for PnP devices (make sure you have the driver handy).

Once the key is recreated you should be able to use the GUI to change the gateway back.

share|improve this answer
On a closer reading, it looks like you tried this already. Sorry for the spam. – John Puskar Feb 2 '11 at 5:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.