Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

cat /proc/cpuinfo on my system gives me different flags for my 2 cores. Can someone explains to me why? I'm running Ubuntu 10.10 kernel 2.6.35-24-generic.

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 23
model name      : Intel(R) Core(TM)2 CPU         E8400  @ 3.00GHz
stepping        : 10
cpu MHz         : 2999.820
cache size      : 6144 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
apicid          : 0
initial apicid  : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni monitor tm2 ssse3 lahf_lm dts
bogomips        : 5999.64
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 23
model name      : Intel(R) Core(TM)2 CPU         E8400  @ 3.00GHz
stepping        : 10
cpu MHz         : 2999.820
cache size      : 6144 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
apicid          : 1
initial apicid  : 1
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dts tpr_shadow vnmi flexpriority
bogomips        : 6000.04
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

I noticed this problem when trying to configure my system for KVM. I'm unable to load the kvm_intel module and I have no other clue why this is so. One of the cpu flags shows me that I support vmx but not the other.

Thanks

share|improve this question

2 Answers 2

Have you tried booting a different kernel/distribution? Perhaps it's just a kernel bug. Try a fedora LiveCD, that should be suitably different from your Ubuntu.

share|improve this answer
    
Excellent advice. Also, is this actually causing any problems? It might just be a weird hamless artifact. –  Phil Hollenback Jan 21 '11 at 7:25
    
I've updated the description with further information on what I was trying to do when I discovered this. I will try Fedora and another kernel version when I get home from work. Thanks! –  Vincent Jan 21 '11 at 14:52
    
Dan, I just tried your suggestion. I got the same result as stated in my question. I did 2 tests: I tried with a different distribution: Fedora 14 kernel 2.6.35.6-45. I also tried with Ubuntu but a previous kernel version, 2.6.32-24-generic. –  Vincent Jan 22 '11 at 1:42
    
Just weird. I suppose it could be a BIOS problem. I would double check that there isn't a BIOS update for your motherboard, and of course that hardware virtualization is enabled in the BIOS. I wonder if some mobos/bioses don't support hardware virtualization at all. You might try locating your hardware on the vmware compatibility list. –  Dan Pritts Jan 31 '11 at 21:37

Looks like the second CPU has these extra flags (comments from linux-2.6.38-rc1/arch/x86/include/asm/cpufeature.h):

dtes64 - 64-bit debug store
ds_cpl - CPL Qual. Debug Store
vmx - hardware virtualization
smx - safer mode
est - enhanced speedstep
cx16 - CMPXCHG16B
xtpr - send tax priority messages
pdcm - performance capabilities
sse4_1 - sse 
xsave - XSAVE/XRSTOR/XSETBV/XGETBV
tpr_shadow - Intel TPR shadow
vnmi - Intel virtual NMI
flexpriority - Intel Flex Priority

I can draw no conclusions. A bunch of these seem to do with virtualization but that's all I can see.

Is it possible that you disabled some of these features in your bios for the second cpu? Are you passing any kernel parameters on boot that could influence the processor configuration? That's all I can think of.

This older Server Fault question about cpu flags seems relevant but not helpful.

share|improve this answer
    
Based on the physical id these are just two cores on the same chip. Unlikely to be disabled features. –  Scott Pack Jan 21 '11 at 3:22
    
Yeah I agree. Just grasping at straws at this point. –  Phil Hollenback Jan 21 '11 at 3:23
    
I didn't change anything in the bios. I just did a double check if I could see weird but my bios settings are pretty bare on this front. Just to confirm, I have only one cpu. As for the kernel parameters they are the default set by Ubuntu. –  Vincent Jan 21 '11 at 3:50
    
At this point I think you would need to start digging in the kernel to figure out why those flags are getting set. –  Phil Hollenback Jan 21 '11 at 3:54
    
Thanks for your help. Do you have any advice for me on the best way to tackle this? –  Vincent Jan 21 '11 at 4:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.